Failed to download metadata for repo

Latest response

Hi,

When I use gdb to debug a C++ program I have these messages :

Missing separate debuginfo for /home/nekcorp/Qt/5.15.2/gcc_64/lib/libQt5Widgets.so.5
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/04/0d62583201617c9d5024a20abcae366f124864.debug
Missing separate debuginfo for /home/nekcorp/Qt/5.15.2/gcc_64/lib/libQt5Gui.so.5
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/bf/fe8076fee9a98e38828285a64e0b7672b377c8.debug
Missing separate debuginfo for /home/nekcorp/Qt/5.15.2/gcc_64/lib/libQt5Core.so.5
Try: yum --enablerepo='*debug*' install /usr/lib/debug/.build-id/7e/528ef9a04c67ed3f2b173a8fe86169032b4dd7.debug

So I try to use the suggested commands and I have the message below :

Errors during downloading metadata for repository 'satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms':
  - Status code: 404 for https://cdn.redhat.com/content/e4s/rhel8/8/x86_64/sat-tools/6.6/debug/repodata/repomd.xml (IP: 23.65.200.83)
Error: Failed to download metadata for repo 'satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

If someone can help me.

Responses

Hi Mohamed,

You have used the option --enablerepo='*debug*'. This means you have enabled ALL debug repositories.
Most of them you won't need, I assume. Are you running a Satellite server ? If not, exclude this specific repo. :)

sudo dnf --enablerepo='*debug*' --disablerepo=satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms install ...

In case other not used, and unnecessary debug repositories produce the same error, disable them as well.
To avoid conflicts, best practice would be to generally enable only those repositories that you really need.

Regards,
Christian

Thank you for your answer Christian

Are you running a Satellite server ? 

I am not an expert, I use Redhat to develop software, so I cannot tell you if I running a Satellite server.

I tested your command :

sudo dnf --enablerepo='*debug*' --exclude=satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms install

and I have the same error message :

Errors during downloading metadata for repository 'satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms':
  - Status code: 404 for https://cdn.redhat.com/content/e4s/rhel8/8/x86_64/sat-tools/6.6/debug/repodata/repomd.xml (IP: 23.65.200.83)
Error: Failed to download metadata for repo 'satellite-tools-6.6-for-rhel-8-x86_64-e4s-debug-rpms': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Hi Mohamed,

The command was just a suggestion ... seems the first option "overrules" the second option.
I'd recommend to check if enabling the BaseOS, Appstream, and CodeReady Builder debug
repositories specifically solve the problem. Otherwise you have to find out in which repo the
bits you want to install reside. As I said, I never enable(d) all repositories to avoid conflicts. :)

sudo dnf --enablerepo=rhel-8-for-x86_64-appstream-debug-rpms --enablerepo=rhel-8-for-x86_64-baseos-debug-rpms --enablerepo=codeready-builder-for-rhel-8-x86_64-rpms install ...

Regards,
Christian