How to make the modification of rrp_mode parameters take effect?

Latest response

The version information of Linux, pacemaker and corosync is as follows:
Linux version 3.10.0-693.el7.x86_64、pacemaker-1.1.23-1.el7_9.1.x86_64、corosync-2.4.5-7.el7.x86_64

When I make the following configuration in the /etc/corosync/corosync.conf configuration file, an error similar to "Value of key 'rrp_token_expired_timeout' is expected to be integer in range" is reported, and the corosync and pacemaker services cannot be started.

totem {
    version: 2
    cluster_name: my_cluster
    secauth: off
    transport: udpu
    rrp_mode: passive
    rrp_token_expired_timeout: 94
    rrp_problem_count_timeout: 4000
    rrp_problem_count_threshold: 2000
}

When I make the following configuration in the /etc/corosync/corosync.conf configuration file, restart the corosync and pacemaker services and the cluster is normal, but the parameters I want to set have not taken effect and are still the default parameters, as follows:

totem {
    version: 2
    cluster_name: my_cluster
    secauth: off
    transport: udpu
    rrp_mode: passive
    rrp_token_expired_timeout=94
    rrp_problem_count_timeout=4000
    rrp_problem_count_threshold=2000
}

Based on the configuration in the previous step, the cluster parameter configuration can be queried through the corosync-cmapctl command, and it is found that the configuration parameters in the previous step have not taken effect, and they are still the default parameters, as shown below:

runtime.config.totem.rrp_autorecovery_check_timeout (u32) = 1000
runtime.config.totem.rrp_problem_count_mcast_threshold (u32) = 100
runtime.config.totem.rrp_problem_count_threshold (u32) = 10
runtime.config.totem.rrp_problem_count_timeout (u32) = 2000
runtime.config.totem.rrp_token_expired_timeout (u32) = 547

So, can you tell me where is the problem? And how should I modify the parameters and make them effective?Thank you advance for sharing your experience here.

Responses

Shui CC - welcome to the Discussion forums.

I'm not familiar with Corosync and Pacemaker - so I'm not immediately sure if this will help, but examine this:

systemctl daemon-reload

and restart the specific servers.

Also check

systemctl | grep fail

and look for any failed services.

You mentioned your kernel you are using which is RHEL7, please see if this link helps?

I imagine you have found this bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1078361? And perhaps you have seen this non-Red Hat article someone wrote? and perhaps this too.

Sorry if this doesn't help you, but you can submit a case with Red Hat since you're using HA.

Kind Regards,
RJ