ipa-server installation failed

Latest response

facing a problem when install ipa-server .
the problem is :

Configured /etc/sssd/sssd.conf
trying https://ipa.cse.local/ipa/json
[try 1]: Forwarding 'schema' to json server 'https://ipa.cse.local/ipa/json'
cannot connect to 'https://ipa.cse.local/ipa/json': [Errno 111] Connection refused
The ipa-client-install command failed. See /var/log/ipaclient-install.log for more information
ipapython.admintool: ERROR Configuration of client side
components failed!
ipapython.admintool: ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information
/var/log/ipaserver-install | tail -n 20 :-
File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 421, in runner
step()
File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 418, in
step = lambda: next(self.__gen)
File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
six.reraise(*exc_info)
File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
value = gen.send(prev_value)
File "/usr/lib/python2.7/site-packages/ipapython/install/common.py", line 65, in _install
for unused in self._installer(self.parent):
File "/usr/lib/python2.7/site-packages/ipaserver/install/server/__init
.py", line 590, in main
master_install(self)
File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 250, in decorated
func(installer)
File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 914, in install
raise ScriptError("Configuration of client side components failed!")

2020-10-26T17:09:52Z DEBUG The ipa-server-install command failed, exception: ScriptError: Configuration of client side components failed!

2020-10-26T17:09:52Z ERROR Configuration of client side components failed!

2020-10-26T17:09:52Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

what can i do now ????

Responses

"[try 1]: Forwarding 'schema' to json server 'https://ipa.cse.local/ipa/json'

cannot connect to 'https://ipa.cse.local/ipa/json': [Errno 111] Connection refused"

This is your issue ^

Can your client ping the ipa server using its domain name? If not, you have a DNS issue.

If it can, it is most-likely a firewall issue. Make sure your ipa server has the correct services open. Last time I tested an IPA server, I opened the following. (Not sure if all are required)

sudo firewall-cmd --add-service=freeipa-ldap --add-service=freeipa-ldaps --add-service=freeipa-replication --add-service=freeipa-trust --add-service=kerberos --perm

sudo firewall-cmd --reload

if i set host name of ipa server on /etc/hosts ,then my client can ping ipa server ..

Ti Saiful,

You mentioned:

2020-10-26T17:09:52Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

DId the log have anything useful?

Please review the log for anything that could be useful for this.

Regards,
RJ

i don't understand this logs.. that's why i shared logfile . please look at this logs, that i already provide

Thank you for adding the logs

Please also evaluate the posts others have made

Please make sure as root you can run yum commands without problems. That sort of error looks like an issue with Yum not working properly

Regards,
RJ