Google chrome freezes system which is running on RHEL 8.2

Latest response

hi

My Dell Precision Tower 3420 is hanging periodically when I run RHEL8.2 and this is quite frequent . I had installed RHEL8.2 yesterday and today I tried installing DevOps tools such as Ansible , kubectl , docker , Jenkins etc .

I have a output of journalctl but the file size is too big .

  1. Can anyone suggest what the commands outputs I need to capture ?
  2. What information to look for in these logs files ?
  3. What fix are necessary in order to stop this hanging issue ?
  4. How can I develop my troubleshooting skills so next time such problem comes I could provide something meaningful conclusions from these logs ?
  5. Is it ok to put log files here in these discussion forums ?

I was working on jenkins update through google chrome on this system when it was hanged in last 2 attempts.

I am pretty confident on this system performance as this is dual boot and I have never ever remember when I had to power off Windows forcefully due to hung state of the system when running on windows . I have 2 seperate HDDs one dedicated for Windows and another dedicated for RHEL 8.2 for isolation from each other .

Responses

Hi Pradeep,

As I already told you in our other discussion, it can be "this and that". First thing that comes to my mind is, you can try another
web browser, such like firefox for example. Now lemme be blunt (helps more than "nice chit-chat") : On one hand you say you
are a newbie, on the other hand you "wildly" add repositories and install whatever you can find ... that's not the best approach.

I would suggest you start by carefully reading the documentation - and then install something (step-by-step ... one package
after the other, add third party repositories only when it's absolutely necessary - install third party software only if you really
do need it. Check if your hardware is compatible, check if all drivers are working properly ... no difference to Windows here ...

You have noticed that I'm always ready and willing to help, but sorry, all this is way too broad ... homework has to get done ! :)
It is extremely difficult to provide you with working instructions, when all we can do is "digging in the dirt" - and then guess ...
Oh, and one thing, please remove the overwhelmingly long journalctl output. It may prevent others from chiming in and help.

Regards,
Christian

To be clear you are dual booting and you have HDD1 -> Windows HDD2 -> RHEL

And RHEL is freezing but windows is not? First thing I'd do is verify the integrity of HDD2 by booting to a rescue USB and using smartctl and xfs_check and making sure you don't have any physical or fs issues to deal with.

Hi Stephen,

Don't think it is a HDD issue - you may have missed the beginning having started in another thread, RHEL works. RHEL boots fine ... it starts freezing when Pradeep starts "working on jenkins update through google chrome" ! :)

Regards,
Christian

Hi Christian - I've specifically run in to this issue when running against bad sectors on RHEL in the past. I've also run into it with bad memory, though with windows running fine I mentally eliminated that.

Hi Christian

My apologies for the same . I have removed journal .

I had to upload it as it was required to diagnose from it but I could not.

I am in need to train myself to be a DevOps engineer hence my intention is only to install DevOps tools under some other formal DevOps training I am going through . All the installations on RHEL8.2 were done from the official websites.

I don't have any other intentions to install anything else other than DevOps tools from official documentations of those vendors.

I searched on internet and found that Jenkins has issue with Chrome and not with Firefox . But it still puzzles me I installed Jenkins today not yesterday .

https://stackoverflow.com/questions/50452302/jenkins-hangs-when-using-chrome-but-is-ok-with-firefox

Anyway thanks for your help and guidance.

with best regards Pradeep Nehe

Again Pradeep, no reason to apologize ... we all were newbies at some point of time ! :)
Firefox works ? Great, so my assumption seems to have been correct. Well, other than
in Windows, you'd differ between "official websites", and official Red Hat repositories.

Regards,
Christian

So to clarify, the browser hangs but not the OS?

Hi Stephen,

Pradeep reported that "working on jenkins update through google chrome" freezes the system. :)

Regards,
Christian

Christian - The title is: "Dell server System hangs which is running on RHEL 8.2"

That generally means to me that the whole system freezes, but it seems like it is only chrome. I'm trying to get clarity.

Sure thing Stephen ... what I said : it freezes Pradeep's system - he has to "hardly shutdown". :)

Regards,
Christian

In. my case when I tried to update Jenkins through chrome when browser hangs I do not have any control on any of the input devices . No keys or mouse responds . Only key that works is CAPS LOCK on and off . Apart from that nothing responds . Even after waiting for a long time . Only way to come out of this loop is to poweroff and power on again from button on the CPU.

If it would have been only browser issue I would not have raised it here . But it is very consistent and I can reproduce it again Hence now only way I will avoid is stop using chrome when using jenkins. Hopefully I will not see this again if this is only related to chrome and jenkins

Pradeep -

  • can you switch to console mode using ctrl+alt+2?

  • Can you ssh into the system after you lose input control?

  • Can you access the jenkins UI from a different system?

Hi Stephen ,

System is hanging daily atleast once . Observation is when I am using google chrome and very consistent . I am not using any other program like Jenkis or anything .

I tried cnt + alt+ 2 as suggested but no response .

This is a standalone desktop server and may be next time I will note down the IP address and will try to do the ssh and will update whether I am able to or no .

I thought initially this is due to Jenkins but now the hanging is only when google chrome is in use. It halts the complete keyboard or mouse movements.

I logged into this forum just because it happend again and I had to hard boot the server now.

Hi Pradeep,

Just came back and saw that you have removed the overly long output ... Thank you for having followed my recommendation ! :)

Regards,
Christian

Hi Pradeep, maybe it is a hard drive, and maybe it isn't. Checking it won't hurt. If it turns out to be a hard drive issue, you can replace it and take actions to recover or rebuild the system.

In any case, since the system seems to be having issues, it may be a good idea to save off any important configurations or other unique data you care about to a location that's not on that system, just in case.

One of my systems at work is currently having issues, and it freezes about every 3 or 4 minutes, pretty annoying. I am going to rebuild my workstation later. If it persists, then maybe I have a hardware issue and I can then run utilities to check the hardware.

However, before going down the path of hardware, here are some other suggestions you can do along with what others recommended above

  • Examine your system logs for anything abnormal.
    • Go to google and examine what the command "top" does and how to sort it for cpu and memory. I suggest this because you can have an instance of "top" running and have it sorted by either memory or CPU usage to see if something happens to spike at the point your system hangs.
    • Attempt to determine if the system hang has to do with a specific program you loaded, maybe one of the programs from the list you mentioned previously in this discussion.
    • Pay special attention to what is going on when the system does hang, did you invoke something?
    • Examine your cron jobs to see if there's a misbehaving cron script.
    • Do a "tail -f /var/log/messages" as root in a terminal window. and see if anything useful appears at or around the times your system hangs.
    • Do a ls -ltr /var/log and see what the most current log or directory is being written to when your system hangs to determine what log to investigate. Maybe what is hanging your system might be writing to a log file, maybe/maybe not.

I can't say the suggestions I've mentioned above will help you determine exactly what is going on. the idea here is to attempt to monitor your system and give yourself visibility to what is happening at the time your system freezes.

Please let us know how this goes and someone here will attempt to assist further.

Regards,
RJ

Thank you for your detailed response . My observation so far is within minutes I launch google chrome on RHEL8.2 onmy machine the system freezes .

I am a new to linux and will learn soon and will try to answer all your queries above based on your guidance . But my conclusion as of now points to one single application that is good enough to hang my system is google chrome . If I launch it , open with 4 pages ( set as defaults ) the system take not more than 5 mins to hang. These are the same default 4 web pages which opens anywhere on windows / mac machine but those system never freezes just because of google chrome as perhaps whole day my google chrome pages are open on them .

i dont think I have to lauch any memory or CPU intensive program to freeze my Dell machine which is quite good in configurations such as Intel Xeon / 16Gb / 1 Tb ( RHEL 8.2 ) + 500 GB ( Windows ) dedicated hard disks.

When I use same machine without opening google chrome I have not yet seen this system freeze issue . Hence I believe there should not be any issue with hardware as I am able to replicate this freeze in minutes I lauch google chrome . Maybe I am wrong but this is my observation so far.

with best regards Pradeep Nehe

Hi Pradeep,

We have "walked some miles together" trying to investigate and analyze the problem ... so, I am curious of course. :)
Since you are using Jenkins with Firefox now - did you experience the freeze again (hope not) - or does everything
work as expected ? If it does, it proves that the system itself runs stable and that the combination Chrome/Jenkins
was the culprit indeed, right as I've assumed in my first response to you above. Wish you a great weekend Pradeep !

Regards,
Christian

hi

The system freeze behaviour is so consistent that perhaps I can reproduce if anyone wants to witness . At this moment I using firefox to write this blog but I am afraid it does not take more than couple of minutes for this system freeze if I open google chrome . It happens daily and it has nothing to do with Jenkins as as of now I am not using jenkis at all but still this behaviour is observed . I am being new to linux I have started learning RHSCA and may be in couple of weeks of learning / training I will be in a position to understand and act on the inputs provided above by you / R J hinton / Stephen .

My only alternative is avoid opening anything in google chrome and use firefox as much as possible . it is just that my other machines I use chrome so often that my links ( URLs ) are stored in chrome . Hence I had to open it somethimes ( unknowingly ) on this RHEL machine . But it does not take more than 5 mins to repent for doing so.

with best regards Pradeep Nehe

Hi Pradeep,

It is a good part of the learning experience with RH (and unix/linux in general) to understand the trigger of the problem, however especially with multi-user systems, being able to accurately describe the problem and its impact on the system is important to.

For instance: if you can ssh to the system, we can probably narrow the problem down to the window manager, meaning that the gui freezes but the system is still running. This gives opportunities to see what is happening on the system while the gui is frozen.

Good luck on your learnings!

Pradeep,

Please examine /var/log/messages and other log files to see if there is anything useful being reported. Also, open a terminal and type the command "top". The "top" command gives you an idea of what is on the system's "mind". You can press "P" and "m" to switch between "CPU" (P) and "memory" (m) which will sort accordingly. Please verify if your /etc/resolv.conf file has your correct DNS servers in case something on your system is trying to routinely "find" a host and is failing as a result.

Regards,<br.RJ

Thanks RJ ,

I will do the same.

I use the same machine but boot in Windows as this is dual boot and extensively use google chrome ( thought Windows ) is on seperate HDD altogether . But for some reason I have a confidence it is just the google chrome which is causing all these problems.

Can you please help me by providing most appropriate link which I should use to 1. Uninstall google chrome completely from my system 2. Install google chrome

I think I did use the steps which were part of this discussion forum but there are too many ways google chrome could have been installed and I seems to have followed one of those .

Now I will follow most appropriate way if you can please recommend or provide a link .

with best regards Pradeep Nehe

Hi Pradeep,

Uninstall :

sudo dnf remove google-chrome-*
sudo rm -r /opt/google/chrome

Add repo :

sudo vi /etc/yum.repos.d/google-chrome.repo

Insert this :

[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64
enabled=1
gpgcheck=1
gpgkey=https://dl.google.com/linux/linux_signing_key.pub

Reinstall :

sudo dnf upgrade
sudo dnf install google-chrome-stable

Good luck ! :)

Regards,
Christian

Hi Pradeep,

Although I have provided you with (known to properly work) instructions how to (re)install Google Chrome, please don't forget
that it is unsupported 3rd party software. You remember what I told you about 3rd party stuff in my first response ? I'm gonna
repeat it : "Add third party repositories only when it's absolutely necessary - and install third party software only if you really do
need it." RHEL ships with the (supported and tested) Firefox web browser - which is known to work perfectly fine. Now, what is
the conclusion ? In case Chrome still generates issues after the reinstall, remove it, use Firefox, and - your problem is solved ! :)

Regards,
Christian

Thanks Christian , I just did all these above .

It took only 2 mins after starting google chrome again system unresponsive as before. Mouse pointer frozen not able to move towards terminal which is another window . Extremely helpless to see this .

Xeon CPU / 16Gb RAM / 1 Tb brand new HDD nothing comes to rescue. Nothing else is running which can suspect CPU or memory utilisation. Just google chrome in a single tab. Not even got a chance to sign in to the same.

Nothing fancy about chrome it is just the habit of storing URLs since ages makes the need for the chrome.

with best regards Pradeep Nehe

Well Pradeep, what can I say ? I'm pretty sure you'll be able to learn how to "store URLs" in Firefox ... won't you ? :)

Regards,
Christian