Desktop Icons not showing

Latest response

Hello,

I noticed that my icons are not showing up on my desktop. I checked the Desktop folder and files and folders are listed there. Is there any way to get this to work?

Responses

Hi Robert,

The concept of modern GNOME is designed to not have and make use of desktop icons. Although there may exist some
workarounds to bring them back, I'd recommend against it because this tends to break the desktop environment in some
scenarios. Best would be to just use the desktop environment as it is intended to be used by the GNOME developers ... :)

Regards,
Christian

Robert, use "gnome-tweaks" command (from a terminal) and poke in the settings (with your non-root account).

[you@yoursystem ~ ] # gnome-tweaks

A window appears. Select Desktop at left. Pick Icons on Desktop and check Show Icons so it is on.

Let us know how it goes

Regards

RJ

Hi RJ,

Thank you for providing this specific solution, it is one of the "workarounds" I've mentioned above. Please let me
add two things. Firstly, gnome-tweaks is not installed by default, to run the command, one has to install it before.
Secondly, the functionality (desktop icons) is deprecated and in newer versions of gnome-tweaks the possibility
to enable this feature is not available any longer ... just for clarification and for your and Robert's information ... :)

Regards,
Christian

Hi RJ,

What I wrote about the default install of gnome-tweaks is valid for RHEL 8 ... not sure (don't remember)
if this is/was valid for RHEL 7 as well. Anyway, I think we should get used to live without desktop icons. :)

Regards,
Christian

Hi RJ,

I did some additional research ... gnome-tweaks is available for RHEL 8 only.
The tool name changed : In RHEL 7 the name is/was gnome-tweak-tool ... :)

Regards,
Christian

Thank you all for your responses. I will keep it the way gnome was intended. Thanks for sharing this information!

You're welcome, Robert ! Good decision ... I'm doing the same. :)

Regards,
Christian

Robert, glad you have it installed.

Christian, I was running gnome-tweaks from a Red Hat 7.7 server that I am using as a workstation to study for RHCE. I don't specifically recall installing the rpm that provides it (provided by gnome-tweak-tool). I did verify to make sure I'm not too crazy that the command under RHEL 7.7 server-with-gui is gnome-tweaks.

Icons on the desktop for me are irrelevant as well, but I know some do want it.

Thanks Christian, and glad you got it resolved Robert

RJ

Thanks for the information, RJ - and for confirming that the tool is included in the base installation of RHEL 7 ... :)

Regards,
Christian

In RHEL8 there are two Gnome desktops, "standard" and "classic" (both using Wayland)

When you log in, click on your user name, then BEFORE you enter your password, click on the cog wheel next to "sign in" You should see multiple choices

I strongly dislike the new Gnome "standard", so I choose "Classic (Wayland display server)" This gives you a start menu in the top left corner, the clock, the status bar, and allows icons, and you don't need the search box. As far as I know, Gnome Classic is supported in RHEL8 and will be forever (I hope).

Thanks for the hint, Gerry ! :)

Regards,
Christian

I just loaded RHEL 8.1 server with gui. gnome-tweaks is an available rpm from RHEL 8 appstream. Not that I care about icons, but someone might.

Regards

RJ

Hi RJ,

Thanks for the information and confirming that the tool has to be installed explicitly (see my comment above).
One has to go to the Extensions tab and enable desktop icons there. Also, please note that this is valid for the GNOME Classic session only - which means you have to select GNOME Classic on the login screen ... right as
Gerry Hickman already mentioned. :)

Regards,
Christian

Thanks for the info Christian :)

Regards

RJ

You're welcome, RJ ! :)

Hi, Whats the point of having a desktop when you can't put icons on it? I want to start a terminal with a mouse click

Best would be to just use the desktop environment as it is intended to be used by the GNOME developers

What is their intention? Clean desktop? How do I solve this problem with the least amount of mousemiles and clicks?

Thanls

Hi Klaus,

The concept of GNOME is to stay out-of-the-way and focus on the work users actually are doing. :)
"The least amount of mouse miles and clicks ?" ... Just hit the Windows key, type a letter and launch.

Regards,
Christian

I've been fighting this with RHEL 8.2 for 2 straight days, and I am not a fan. Luckily, I finally found gnome-tweaks as already mentioned, and that made the Gnome experience 1000-fold better. Sadly, I still couldn't get custom desktop icons (I don't give a lick about "Home" and "Trash") working.

Just now I accidentally right-clicked on a MyApplication.desktop file from the desktop NOT the Files application navigated to ~/Desktop/. There is a handy little option called "Allow Launching" that magically solves the entire issue.

My use of RHEL 8 on my main workstation for "Work" since I've been now allowed to work from home has been great. This worked for me also. I used a gnome-extension to allow for for the option to right click and open terminal, as a by product Icons appeared on my desktop with .desktop Recently I installed Steam, and all of the icons showed up as basically blank files similar to how a text file would appear. While right clicking on one of them I noticed the explicit "Allow launching" is part of the options along with properties. This "Allow launching" option used to be available in older Gnome version before (If I'm not mistaken), but then, when you'd right click and go to properties of the .desktoop file it would appear towards the bottom of the Basic Tab as a check-able option. Thanks for sharing that as now all of my icons are now showing correctly once again.

Not having shortcuts on the desktop is a huge problem for alot of users. Telling people they need to learn to live without is not an answer. Thank you for providing different ways to get this to work.

Make sure you have a ~/Desktop/ !!

I just built a RHEL 8 desktop from scratch, not using package groups to avoid unnecessary bloatware.

I tried coping a /usr/share/applications/*.desktop file to my Desktop, and was told that ~/Desktop/ did not exist.

When I created it, the desktop icons magically appeared !

Is linux turning into MS? only eat what tha cook wants to serve? the freedom of choice is a very important aspect of linux in general, and the desktop environment is a key part of that. Red Hat already lacks alternative desktop environments by default, and then using the lame excuse 'use it as the developers intended' makes my blood boil, if I wanted that I would be using windows.

I also distribute custom software for my customers. All my applications are available from the Desktop with .desktop and folders in ~/Desktop. My documentation is based on this feature and my customers are used to it. My customers use Red Hat because of the software support particularly the security support. Removing features with each new release of the OS negates the use of Red Hat software for my company. I will look for something different. RHEL 8 will be the last Red Hat OS I will be using.

Hi Serge, and welcome

Thanks for letting us volunteers know this. To let Red Hat know this, submit a case. There's little chance they will see your paragraph above.

Regards,
RJ

In RHEL8, you can create desktop shortcuts by simply switching to Gnome "classic", as explained above.

In RHEL9, you can also create desktop shortcuts, but you have to install

gnome-shell-extension-desktop-icons.noarch

It's worth noting, however, that both Gnome and RedHat hate people using desktop icons, not sure why. My guess is that not many people use linux desktop, e.g. they might use a Mac client and ssh into their servers.

Hello Gerry,

This package works nicely. I agree with your statement. Just a rhetorical question. Why still have "Classic..." options in GDM if you're doing to modify it with every version or RHEL? I thought Classic stands for something. Stay the same, no changes perhaps?

The icons are no longer showing once the Screen Lock has been engaged and I enter the password to get back to the desktop. A logout/login takes care of the problem. Any idea?

In RHEL8, and when using Gnome Classic, you should see two desktop icons by default

1. 'username'
2. 'Wastebasket'

You should also see a top bar with menus on the left, and power buttons on the right. You should also see a taskbar at the bottom of the screen with workspace boxes on the right. Assuming all is correct, you can lock the screen, then unlock, enter password and the two icons come back again. If any of that isn't working, it probably means there's something wrong with the setup.

There is no problem with RHEL 8. The problem is with RHEL 9. Install the OS, login as user root, select GNOME Classic, enter the password. There is no icon. I install gnome-shell-extension-desktop-icons-40.6-1.el9.noarch.rpm, reboot, and log as user root. The icons 'Home' and 'Trash' are present and the "cursor menu" is present. Created a folder under ~/Desktop which appears on the desktop. In Settings->Privacy->Screen Lock, set Blank Screen Delay to 1 minute, enable automatic screen lock, set Automatic Screen Lock Delay to 30 seconds. Wait two minutes, enter the password to get back. The icons are no longer present. The cursor menu is no longer available. If I log out and log back in, everything is back to normal.

I'm not seeing the problem in RHEL9.

I can login and see the icons, then manually lock the screen, then press escape, then icons come back. I have not tried the lock screen with the timer.

Can you clarify what you mean by "cursor menu"?

Can you check if you are using Wayland (or x.org)

Can you test it as standard user, you should not be logging into GUI as root.

I lock the screen using the lock button and unlock to it by entering a password. The icons and the cursor menu diappear. The cursor menu is the menu shown when the cursor is on the desktop background and you press the right mouse button. I use "GNOME Classic" or "GNOME Classic on Xorg". Any other option does not show the HOME icon, the trash can icon nor the application and folders un ~/Desktop. I tested it with a standard user. RHEL 9 exhibits the same behavior.

I've now tested using the lock screen on a timer. This was set up in "Gnome settings : Privacy".
I set screen blank to one minute and auto lock screen to one minute.
I waited for one minute for the screen to go blank, then another minute to trigger the lock.
I then pressed "Esc" and got the 'gdm' login screen, with my user name.
I enter the password, and the desktop comes back with all icons showing.
The right-click menu is also working.
Can you check these commands on your machine before and after the lock screen:

echo $GNOME_SHELL_SESSION_MODE
echo $DESKTOP_SESSION
echo $XDG_SESSION_DESKTOP
echo $XDG_CURRENT_DESKTOP
echo $GDMSESSION

The variables are the same.

Variables with icons and right-click menu showing:

GNOME_SHELL_SESSION_MODE classic DESKTOP_SESSION gnome-classic-xorg XDG_SESSION_DESKTOP gnome-classic-xorg XDG_CURRENT_DESKTOP GNOME-Classic:GNOME GDMSESSION gnome-classic-xorg

Variables with icons and right-click not showing:

GNOME_SHELL_SESSION_MODE classic DESKTOP_SESSION gnome-classic-xorg XDG_SESSION_DESKTOP gnome-classic-xorg XDG_CURRENT_DESKTOP GNOME-Classic:GNOME GDMSESSION gnome-classic-xorg

I did a lot of things on this RHEL 9.0. So, I will re-install RHEL 9.0 again and set it up to show the icons and the right-click menu and run the test again. Thanks for your help.

I thought it might have jumped away from 'classic' mode, but according to your variables, it's still in classic mode.

On my system, I installed using the 'workstation' role, and I'm running nearly everything on defaults.

It would be good if you can test this on a clean system, but also try to find out why it's not working on your current system.