Unable to load http2 on RHEL 7.7

Latest response

Hi All,

Environment:

Red Hat Enterprise Linux Server release 7.7 (Maipo)
Server version: Apache/2.4.6 (Red Hat Enterprise Linux) and
OpenSSH 1.0.2

Issue:
I am having trouble enabling HTTP/2 protocol in apache. Following the links from previous posts but things aren't working out:
*https://access.redhat.com/solutions/3050901
*https://access.redhat.com/solutions/2063063

While running apachectl configtest i get this error: "httpd: Syntax error in /etc/httpd/conf/httpd.conf and /etc/httpd/conf.modules.d/00-base.conf: Cannot load modules/mod_http2.so into server: /etc/httpd/modules/mod_http2.so: cannot open shared object file: No such file or directory"

And i have no clue where to download it mod_http2.so, in case i have to manually place it in /etc/httpd/modules.

Any help will be greatly appreciated.

Responses

Hello Abdullah,

You need the httpd24* rpm set, for the standard httpd rpm set is based on an Apache version prior to the http2/0 compatible update.

The software and configs will be installed under /opt/rh/httpd24/root/* directories.

You will need yum install httpd24* to install this version.

Warning:This is an abstract, check the RHSCL documentation for details on how to enable httpd24 the official way

1) systemctl mask httpd

2) systemctl stop httpd

3) migrate all your manual configs from /etc/httpd/conf.d to /opt/rh/httpd24/root/etc/httpd/conf.d

4) systemclt enable --now httpd24-httpd.service

Further reading: Using Apache httpd 2.4 on Red Hat Enterprise Linux 6

Hi Jan,

Thank you for providing the details and useful links. After applying these steps i ran a test and getting these results:

$ curl -I -v -k https://google.com
* Connection to Proxy
> CONNECT google.com:443 HTTP/1.1
< HTTP/1.0 200 Connection established
HTTP/1.0 200 Connection established
> HEAD / HTTP/1.1
< HTTP/1.1 301 Moved Permanently
HTTP/1.1 301 Moved Permanently
<Server: gws
Server:gws

I have not done any further testing but getting HTTP/1.1 302 instead of 200’s and Server: gws instead of actual Apache/2.4.*(Red Hat) seems problematic, please let me know if you have any insights on this.