Jboss webserver 3.1.5

Latest response

Hello,

I am running jboss webserver 3.1.5 and using java SE8 (java 1.8).
In 2019 you need subscriptions for 1.8.
For java 11 (java 1.11) you dont need the subscriptions.
When will jboss webserver 3.1.5 support java 1.11?

Kind regards,
Jeremy

Responses

Thanks for contacting Red Hat support. There are no plans to support JWS 3 on Java 11. What OS do you run on? Are you using Oracle JDK 1.8 currently? If so, options to consider moving forward are:

-Acquiring support with Oracle for ongoing JDK support and updates

-Continuing to use Oracle JDK 1.8 without any extended support or further updates from Oracle

-Switching from Oracle JDK to Red Hat's OpenJDK. This is available as a package on Red Hat Enterprise Linux. This week, we also made OpenJDK available for production support on Windows as well:

Announcement: https://www.redhat.com/en/about/press-releases/red-hat-introduces-commercial-support-openjdk-microsoft-windows Download: https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=distributions&product=core.service.openjdk&version=1.8.0.191 Documentation: https://access.redhat.com/documentation/en-us/openjdk/8/ Lifecycle and support policy: https://access.redhat.com/articles/1299013