Latest response


Our Satellite 6.3 server connects to Redhat via a proxy server which is configured and working. As part of trying to register a client and running the it is rebuilding the rhsm.conf file on the server as part of the 'katello-ca-consumer-latest.noarch.rpm' install. This is causing problems because it has proxy settings in it so it is trying to go to the Satellite server when registering via the proxy server and failing with below error:

[RUNNING], [2018-03-15 13:20:52], [/usr/sbin/subscription-manager register --org '****' --name '***********' --activationkey 'AK_REG_********' --serverurl=https://***************:443/rhsm --baseurl=https://************/pulp/repos --force]
[ERROR], [2018-03-15 13:21:02], EXITING: [/usr/sbin/subscription-manager register --org '*****' --name '**************' --activationkey 'AK_REG******' --serverurl=https://***********:443/rhsm --baseurl=https://*************/pulp/repos --force] failed to execute properly.
Proxy connection failed, please check your settings.

Where is it pulling this rhsm.conf file from and in particular the proxy settings from I tried removing them from the rhsm.conf on the satellite server and re-trying but same error.

Any help much appreciated


I had this exact same problem. It turns out that the script overwrites /etc/rhsm/rhsm.conf with the contents of /etc/rhsm/rhsm.conf.kat-backup . In my case, that kat-backup file had out-dated proxy information, so would merrily run until that point and then complain "Proxy connection failed, please check your settings." Kind of a "duh" move if you ask me. Anyway, I solved this by removing all the proxy entries in /etc/rhsm/rhsm.conf.kat-backup, and the script worked fine.

By default, when installing the katello-ca-consumer* package, the subscription-manager config command is called in order to setup the client. This will preserve any proxy settings configured on the client. If your clients were registered to the portal then they probably also have proxy settings in their rhsm.conf file.

Next, (and subscription-manager) will honor any http_proxy or https_proxy values if set.

Lastly, supports the -S option, which allows additional options to be passed to the underlying subscription-manager commands

  -S ARGS, --subscription-manager-args=ARGS
                        Which additional arguments shall be passed to

This can be used to either explicitly set or negate a proxy value.

i am facing the same issue. redhat 7 works as expected with proxy. but rhel 6 fails with the below error. can some one help here

Proxy connection failed, please check your settings.

I had the same issue in RHEL6 ,could some one elaborate the "-S ARGS" option how to use ? for example if I would like to pass the proxy server name and port via bootstrap script ,that case is the below one is correct ? ./ - S server.proxy_hostname= proxyserver -S server.proxy_port=1000