EAP 7 Compatibility with Java 6 (jrockit-jdk1.6.0_45-R28.2.7-4.1.0)

Latest response

Hi all,

I would like to know if EAP 7 is compatible with JAVA 6 (jrockit-jdk1.6.0_45-R28.2.7-4.1.0) or not?

We have some implemented applications under JAVA 6 and we don't want to upgrade to JAVA 8.

Best Regards,
Ahmad Basseem

Responses

Hi Ahmad,

Short answer: no.

Longer answer: At the moment, JBoss EAP 7 is only supported on Java 8. You can see the supported JDKs here.

If you want Java 7 or Java 6 support, you will need to use JBoss EAP 6. You can see the supported JDKs for JBoss EAP 6 here.

Also, please note that JRockit is not a supported JDK for JBoss EAP. You will need to use a JDK that is listed on the supported configurations pages above.