reverse lookup error ** server can't find x.x.x.x.in-addr.arpa.: NXDOMAIN

Latest response

Hi folks,
I have configured a recursive DNS server in two virtual machines(virtual Box) hosting RHEL 7 to work on an Oracle RAC lab but my reverse lookup is not working .
The same configuration has worked very well on RHEL6.4 without a hassle but I can't seem to grasp why the forward lookup is ok while the reverse one is messed up.
any encountered such issue yet ?
A clue or an insight to spot the syntax error( or anyrhing I might 've done wrong) would be very appreciated

Here is my configuration steps and files on the master server :

Hostname : london1
Domain : evilcorp.com
ip : 192.168.78.51 listening port 53 network 192.168.78.0

/etc/named.conf

// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS server as a caching only nameserver (as a localhost DNS resolver only).
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
        listen-on port 53 { 192.168.78.51; };
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named";
        dump-file       "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query { 192.168.78.0/24; localhost; };
 allow-transfer { 192.168.78.0/24; };
        recursion yes;

        dnssec-enable yes;
        dnssec-validation yes;
        dnssec-lookaside auto;

        /* Path to ISC DLV key */
        bindkeys-file "/etc/named.iscdlv.key";

        managed-keys-directory "/var/named/dynamic";

        pid-file "/run/named/named.pid";
        session-keyfile "/run/named/session.key";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
        type hint;
        file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";

zone "evilcorp.com" {
 type master;
 file "evilcorp.com";
};
zone "in-addr.arpa" {
type master;
file "evilcorp.com.rev";
allow-update { none; };
};

=========

THE zones

  1. forward zone : evilcorp.com
    [root@london1 named]# cat /var/named/evilcorp.com
$TTL 3H
@            IN SOA london1 hostmaster (
101 ; serial
1D ; refresh
1H ; retry
1W ; expire
3H ) ; minimum
              NS  london1
              NS  london2
localhost     A   127.0.0.1
london1       A   192.168.78.51
london1-vip   A   192.168.78.61
london1-priv  A   172.16.100.51
london2       A   192.168.78.52
london2-vip   A   192.168.78.62
london2-priv  A   172.16.100.52
london-cluster-scan A 192.168.78.251
london-cluster-scan A 192.168.78.252
london-cluster-scan A 192.168.78.253
  1. reverse zone : evilcorp.com
    [root@london1 named]# cat /var/named/evilcorp.com.rev
$TTL 3H
@              IN SOA london1.evilcorp.com. hostmaster.evilcorp.com. (
101 ; serial
1D ; refresh
1H ; retry
1W ; expire
3H ) ; minimum
               NS  london1.evilcorp.com.
               NS  london2.evilcorp.com.
51.78.168.192  PTR london1.evilcorp.com.
61.78.168.192  PTR london1-vip.evilcorp.com.
51.100.16.172  PTR london1-priv.evilcorp.com.
52.78.168.192.in-addr.arpa.  PTR london2.evilcorp.com.
62.78.168.192  PTR london2-vip.evilcorp.com.
52.100.16.172  PTR london2-priv.evilcorp.com.
251.78.168.192 PTR london-cluster-scan.evilcorp.com.
252.78.168.192 PTR london-cluster-scan.evilcorp.com.
253.78.168.192 PTR london-cluster-scan.evilcorp.com.

[root@london2 ~]# cat /etc/resolv.conf

# Generated by NetworkManager
search evilcorp.com
nameserver 192.168.78.51
nameserver 192.168.78.52

A- forward TEST :OK

[root@london1 ~]# nslookup london1
Server:         192.168.78.51
Address:        192.168.78.51#53
Name:   london1.evilcorp.com
Address: 192.168.78.51

[root@london1 ~]# nslookup london1.evilcorp.com
Server:         192.168.78.51
Address:        192.168.78.51#53
Name:   london1.evilcorp.com
Address: 192.168.78.51

reverse TEST: ERROR

[root@london1 ~]# nslookup 192.168.78.51
Server:         192.168.78.51
Address:        192.168.78.51#53

** server can't find 51.78.168.192.in-addr.arpa.: NXDOMAIN **

I also attached a zip containing all the related files

Attachments

Responses

Problem solved by adding the following in the /etc/named.conf file.

empty-zones-enable no; 

(heck !!!!!!! they changed the default value to yes in the recent version ). 1 wasted week for such stupid entry

Hi i am getting below error help on this ;; Got SERVFAIL reply from 172.17.70.72, trying next server