change to mwm

Latest response

Good Morning

I want to load the window manager mwm (motif Windows manager) in RHEL6. In previous versions such RHL4 was a directory / usr / share / switchdesk with different graphics environments that could carry mwm, fwm ....

Now how can we change mwm?

thank you very much
regards

Responses

Hi,

You can install the xorg-x11-xinit-session package, which adds a User script option to GDM (once you select a username). This makes GDM take into account the following files (in that order):

~/.xsession
~/.Xclients
/etc/X11/xinit/Xclients

You can use those files to specify what WM you want to launch. So, to start mwm for a particular user, something like this is needed (provided that no ~/.Xclients file exists, and mwm (openmotif package) is installed):

echo "/usr/bin/mwm" > ~/.Xclients
chmod +x ~/.Xclients

Hi,
Thanks for your answer. The package xorg-x11-xinit-session is not in the DVD 6.¿Existe in RedHat Red Hat platform to download this package ?.

On the other hand I tested it on an old machine with Red Hat 4 and mwm that users do not have the file ~ / .xsession.

Thank you very much in advance
regards

hi,

my computer has no internet connection for enterprise security

Thanks
Regards

Hi,

The xorg-x11-xinit-session package is a part of the Optional channel. You can either download it, transfer to your other computer, and then install locally, or you can just create the file it contains.

The package provides only a single, short text file, which you can create manually. The file is /usr/share/xsessions/xinit-compat.desktop, and it has this contents:

[Desktop Entry]
Name=User script
Comment=This session runs ~/.xsession or ~/.Xclients if available
Exec=sh -c "exec ~/.xsession || exec ~/.Xclients || exec /etc/X11/xinit/Xclients"

When you create the file, run the commands I listed above:

echo "/usr/bin/mwm" > ~/.Xclients
chmod +x ~/.Xclients

(This will create a new ~/.Xclients file.)

And you should be all set.

I do not know why not start happening and the mwm desk.

I have checked the file permissions /root/.Xclients
rwx r_xr_x

I have also verified that the file /usr/bin/mwm.
When I boot level 3 and run xinit -e / usr / bin / start mwm desk

Thank you very much in advance
regards

Sorry is in complete message.

Thank you about answer

I have installed xorg-x11-xinit-session-1.0.9-14.el6.x86_64.rpm package
I copied /usr/share/xsession/xinit-compat.desktop to /root/.xsession
I have created a /root/.Xclients file with the following content:
/usr/bin/mwm
When I reboot the machine, the root user starts the gnome desktop
I do not know why not start happening and the mwm desk.

I have checked the file permissions /root/.Xclients
rwx r_xr_x

I have also verified that the file /usr/bin/mwm.
When I boot level 3 and run xinit -e / usr / bin / start mwm desk

Thank you very much in advance
regards

Hi Valentín,

There seems to be some misunderstanding. You should not copy the xinit-compat.desktop file to .Xclients. Let me repeat the whole procedure:

  1. Install the xorg-x11-xinit-session package.
  2. Create the ~/.Xclients file with the following contents:
    /usr/bin/mwm
  3. Make the ~/.Xclients file executable by running:
    chmod +x ~/.Xclients
  4. Remove any existing ~/.xsession file. You don't need it.
  5. Log out and select the option User script in GDM.
  6. mwm should be launched.

Also, I would suggest not running any graphical desktop as the root user. It's generally considered unwise. It's better to run the graphical desktop as a regular user and only switch to root on the command line or in particular GUI admin tools if you need to perform administration tasks.

Hi Robert

Thank you very much. Now works when I choose "user script".
But how I can do it permanently ?.

Thank you very much in advance
regards

GDM remembers the last selected option.

If, for some reason, it doesn't remember it, you can remove the GNOME option altogether by removing/renaming the GNOME session file. Then the User script option will be used always (and it will not be possible to choose GNOME) For example:

# mv /usr/share/xsessions/gnome.desktop /usr/share/xsessions/gnome.desktop.dontuse

Hi Robert,

It is work fine.
Thank you very much.

best regards.
Valentín

Hello, I hope someone is still monitoring this thread. I am running RH6.8, and for legacy reasons I need to run MWM. I have installed openmotif and the xorg-x11-xinit-session package. I can force mwm to run by going to run level 3 and rerunning xinit, but cannot make MWM the default window manager, nor can i get it to show the "User script" option.

Besides the files listed above is there any other moving parts to making this work?

Thanks in advance.

Hi David,

Yep, I was notified of your new comment. Just a quick note to let you know I'm looking into it. I need to test the thing locally first because I'm not sure what the problem might be.

I tried this as well: https://access.redhat.com/solutions/60618 (no change).

Thanks in advance.

Hi David,

I just tried the procedure described above in this thread on a fresh install of RHEL 6.8, and it works fine.

On the off chance that this isn't clear... Do you know that you're only shown the drop-down menu for choosing the session to log in to after you click on the username you want to use in GDM?

Can you post or email your anaconda-ks.cfg file that you're using to build your system along with any additional rpms added?

I used the same procedure for Redhat 7.4 Enterprise Workstation. I changed default window manager to mwm, but the problem is that i cannot do any action on mwm. Only right click menu is appeared (Root Menu,New window,Shuffle up, etc.) but cannot do anything with the options of the menu except "Quit". What i am missing ? I downloaded and installed the motif package (motif-2.3.4-12.el7_4.x86_64.rpm) and also some missing dependencies for motif (libXp-1.0.2-2.1.el7.x86_p4 and xorg-x11-xbitmaps-1.0.1-9.1.e6.x86_64). Could you help me ?