Filesystem passthrough "virtio-9pfs" support in KVM in RHEL7 ?

Latest response

is this feature planned for RHEL7x KVM virtualization?

I checked the RHEL 7.0 and it's not there yet.

Thank you


Noone knows anything? :[ I'm not surprised though, i can't find any proper info around.

I'd like to do:
use the FS passthrough in scenario, where RHEL 7 insecure guest (facing to outworld internet) would have provided physical NIC from RHEL 7 host and thus, the KVM guest would be completely separated (sandboxed) from host machine networking.

I'd like to backup some files though to the host and the 9pfs seamed to me to be a way.

Sadly, in RHEL 7 there is even less support seamingly compared to RHEL 6 - there is not even kernel module compiled in natively:

cat /boot/config-3.10.0.-123.el7.x86_64 | grep -i 9p

CONFIG_NET_9P is not set

while e.g.

cat /boot/config-2.6.32-358.6.2.el6.x86_64 | grep -i 9p

CONFIG_NET_9P_DEBUG is not set

CONFIG_9P_FS is not set

So there is no plan to support this feature on RHEL 7? That remain total mystery to me and maybe even to RHEL devs? :]

Hi Karel. Sorry for the lack of response to this one. The long weekend in the US probably has something to do with that. ;)

I'll see if I can track down an answer for you.

Thanks a lot!
I just wander, in Fedora it was introduced already some time ago, so i hoped, it might get at some point to RHEL7.
But as it looks atm., devs even removed the 'CONFIG_9P_FS' from RHEL7 kernel, which is quite discouraging move.
And no info to be found anywhere...

Thank for hlp,

Hi Karel,

RHEL only provides a subset of kernel modules and QEMU device models, that are well tested and that Red Hat will be able to support for the 10 years of product lifetime. Unfortunately, virtio-9pfs does not satisfy these requirements yet:

  • it is not very well documented upstream, to the extent that it's hard to understand what works and what doesn't; the IBM team who worked on it moved to other tasks.

  • it has a privileged (setuid) component that may require special care in order to support SELinux and sVirt; the component is also not very well documented, which makes this problem worse;

  • it is not supported on Windows guests.

As of RHEL7, the recommended general-purpose file service is NFS; if it is not enough for your purpose, raising a
ticket through your regular Red Hat support channels will make your needs known to the support, product management and development teams.

I don't know the reason why CONFIG_9P_FS was enabled in RHEL6 and disabled in RHEL7; this was done independent of the choice to disable virtio-9pfs, and I wasn't involved in that decision.

Thank You for valuable information.

RHEL 7.3 just being released ... I realized that sharing files between hosts and guests using 9p ( ) is still not possible. As 9p is a quite reliable and useful solution, I am wondering if there is a chance to have it included in the near future ?

Hi Christian,

my reply from two years ago is still valid, and explains why 9p is not as reliable as it seems. However, Red Hat is working on support for AF_VSOCK (virtio-vsock), so that NFS can be used between guests and hosts without interacting with e.g. the host and guest's firewall setup. In fact, this will be usable for more than just file system sharing.

We cannot really tell you yet when or if this will be included in RHEL, but for now there are copr packages for Fedora 24 at

You need at least the kernel (for both guest and host) and qemu-kvm packages.

For more info on how to run:

Thank you for this information, Paolo ! :)

VirtFS 9P filesystem passthrough in CentOS 7 (also applicable to RHEL 7).

Is this still being worked on? I am trying to use RHEL 8.3 on s390x and am getting the error:

if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)

libvirt.libvirtError: internal error: qemu unexpectedly closed the monitor: 2021-04-02T15:24:13.433846Z qemu-kvm: -device virtio-9p-ccw,id=fs0,fsdev=fsdev-fs0,mount_tag=/tools,devno=fe.0.0007: 'virtio-9p-ccw' is not a valid device model name

I need to share a few multi volume filesytems between guests, but if looks like the HiperVisor has to be the owner.

The NFS solution is no good here, because I'm trying to use macvtap connectivity which is supposed to have better performance but for some reason does not allow communication between Guest and HyperVisor.

So I either need the passthrough of filesystems to work or if someone can point me to virtual network instructions that actually allow the guests to talk to the HyperVisor so NFS will work, that would be appreciated.