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Red Hat OpenShift Container Platform へのパッチの適用またはアップグレードに関するプロアクティブケースの作成方法

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Container Platform (RHOCP)

Issue

  • 実稼働環境の OpenShift Container Platform クラスターのアップグレード方法を教えてください。
  • アップグレードが実行中であることを Red Hat に通知し、適切なリソースを利用できるようにするには、どのようにケースを作成すればよいですか?
  • 週末や勤務時間外にプロアクティブチケットを作成する場合、Red Hat Support チームにとって役立つ情報は何ですか?

注記:

  • 新規のインストールの場合は、プロアクティブケースを作成する必要はありません。このような状況で問題が発生した場合は、通常のサポートチケットを作成してください。また、新規のインストールは、Red Hat Support における重大度レベルの定義 に従い、重大度 1 (緊急) とみなされない点に注意してください。
  • Guidelines for a Successful Support Engagement に従って、サポートケースごとに 1 つのクラスターアップグレードが行われます。クラスター内に Red Hat OpenShift Data Foundation (ODF) や Red Hat OpenShift Virtualization がインストールされている場合、それらのコンポーネントについては別個のサポートケースを作成する必要があります。
  • アップグレードの前後で、潜在的な問題や既存の不具合が見つかった場合は、個別に専用のサポートケースを起票してください。

Resolution

はじめに - プロアクティブケースとは?

プロアクティブケースとは、Premium 契約のお客様が、計画的なアップグレード、移行、パッチ適用、またはその他のメンテナンスアクティビティーについて、Red Hat Support チームに事前に通知する方法です。一般に、これらのイベントは、通常の営業時間外に発生します。

実施予定の作業について事前に把握しておくことで、Red Hat 側でアップグレード前にクラスターの状態を確認できます。また、問題が発生した際に、速やかにテクニカルサポートを提供できるよう適切な情報をそろえ、万全の準備を整えることが可能になります。

注記: 新規のインストールは、重大度 1 の 重大度レベルの定義 に一致しないため、プロアクティブケースの対象外となります。新規のインストール中に問題が発生した場合は、通常のサポートケースを作成してください。

プロアクティブチケットを開くための検討事項

timeframe または window of maintenance の期間中、ソフトウェアの欠陥が原因でないシナリオにおいては、Red Hat がシステムへ リモートアクセスすることはありません。このような状況には、以下が含まれます (ただし、これらに限定されません)。

Performing system administration functions
Standing by during migrations or upgrades
Debugging non-Red Hat software
Monitoring your environment
Walking through documentation and upgrade procedure/workflow.
Configurations or advisement of pre-upgrade configurations/issues.
注記

Red Hat Support チームは、メンテナンス期間のコール/ブリッジ/チャネルには参加しません。ただし、メンテナンス期間の開始後は、プロアクティブケースの更新を積極的に監視します。

前提条件

  • アカウントには、アクティブな Premium OpenShift サブスクリプションが 必要 です。

    • アクティブな Standard がアカウントにある場合: Red Hat Cloud Suite、Standard (2 ソケット、32 コア) サブスクリプションがある場合、またはクラスターが (Red Hat ではなく Microsoft がサブスクリプションを提供する) パートナー製品としての ARO (Azure Red Hat OpenShift) である場合は、そのアカウントはプロアクティブケースを作成する対象となります。
  • クラスターがアップグレード可能な状態であることの確認や、実施日に向けた適切なリソース確保を行うため、プロアクティブケースは作業開始の 数日前 (可能であれば 7-14 日前) までに申請していただく必要があります。

    • クラスターがアップグレードに適した健全な状態であるかを確認するには時間を要します。また、場合によってはアップグレード前に事前の対処が必要となることもあり、それが行われないと、作業の遅延や予期せぬトラブルを招く恐れがあります。
    • アクティビティーの対象期間に 週末 が含まれる場合は、予定されるアクティビティーの 少なくとも 4 営業日前 までにプロアクティブケースを作成する必要があります (たとえば、予定されるアクティビティーの前の火曜日の営業終了前までに作成)。
      注記: 週末に実施予定のプロアクティブケースにおいて、作業日の 4 営業日前までに申請されなかったものは、「遅延登録」扱いとなり、通常の Follow the Sun (24 時間体制) のワークフローで処理されます。このような場合、Red Hat では、週末に適切なリソースが配置されることを保証できません。
    • プロアクティブサポートケースの対象言語は 英語のみ となっています。これは、世界中のあらゆる場所の、さまざまなチームから最適なエンジニアを割り当てるためです。
  • Red Hat のサポートを利用する際のベストプラクティスが記載されたアーティクル記事 Reference Guide for Engaging with Red Hat Support を参照し、サポートケースに関する理解を深めることが推奨されます。

  • 今後予定されるイベントに関連したあらゆる詳細情報を準備してください。変更やアクティビティーについて話し合う上で役に立ちます。

  • アカウントに テクニカルアカウントマネージャー (TAM)、ソリューションアーキテクト (SA)、または カスタマーサクセスマネージャー (CSM) がいる場合は、プロアクティブケースを計画する際にそれらの担当者と連携してください。

  • OpenShift 4 cluster upgrade pre-checks requirements に従って、クラスターの全体的な状態を確認します。

  • クラスターで使用されている Kubernetes の非推奨となった API に関する情報を取得するには、Navigating Kubernetes API deprecations and removals を確認してください。

  • クラスターに Red Hat OpenShift Data Foundation (RHODF) がインストールされている場合は、implications to consider when upgrading OpenShift Data Foundation も参照し、ODF アップグレード用の別のサポートケースを開いてください。

  • クラスターに Red Hat OpenShift Virtualization または Migration Toolkit for Virtualization (MTV) がインストールされている場合は、How to open a Proactive case for OpenShift Virtualization/MTV も参照し、そのための別のサポートケースを開いてください。

プロアクティブサポートケースの作成

サポートケース を作成し、以下のように必要な情報を入力します。

  • ケースのタイトル - 冒頭 に "[Proactive]" と付け、バージョンアップグレードを要約する必要があります。例:

    [PROACTIVE] Production/Integration/Development OpenShift cluster upgrade from 4.16 to 4.17
    
  • 重大度 - 重大度レベル 3 でケースを作成します。Red Hat では、問題が発生した場合に適切なリソースが割り当てられるように、アクティビティーの当日またはアクティビティーの開始時に、重大度を 1 にリセットすることをお客様に推奨しています。

  • ケースの説明 - できるだけ多くの詳細を説明します。以下に例を示します。
    • イベント中に発生する特定のアクティビティー
    • 環境
    • インフラストラクチャー
    • 関連するシステム
    • アップグレード中の他のコンポーネント
  • イベントの日時 - メンテナンス作業期間の予定 開始日時終了日時 を、タイムゾーンを含めて明記してください。
  • 連絡先情報 - 第一連絡先と第二連絡先、電子メールアドレス、電話番号 (国コードと地域コード付き) を入力します。これは、ケースを作成した人とメンテナンス作業を行っている人が同じではない場合に特に重要です。
  • データの添付 - アップグレード作業を実行する前に、関係するすべてのシステムの最新の must-gather レポートと、必要に応じて sosreports を収集します (以下の 診断手順 セクションを参照)。
    • システムが少ない場合は、sosreports を収集する際にサポートケースに添付してください。それ以外の場合は、ローカルに保管し、すべての sosreport が収集されたことを確認するメモをケースの説明に記入してください。これは、すでに存在する潜在的な問題を阻止し、アップグレード後の新たな問題を特定する上で役に立ちます。
    • Navigating Kubernetes API deprecations and removals に従って、クラスターで使用されている Kubernetes の非推奨となった API に関する情報を収集します。

注記: (いずれかのアカウントの) TAM または CSM による例外的な推奨がある場合を除き、一度に複数のマイナーバージョンを更新することは サポートされていません。それにもかかわらず、同じメンテナンスウィンドウ内で複数のバージョンをアップグレードする必要がある場合は、リソースの都合上、Red Hat 側で専任の担当者を配置することは保証できない点にご注意ください。

プロアクティブケースの例

  • ケースのタイトル:

    [PROACTIVE] Production OpenShift cluster upgrade from 4.16.23 to 4.18.12
    
  • ケースの説明:

    In two weeks, on Saturday July 22nd,  we are planning to upgrade our production cluster from OCP X.Y.Z to OCP X2.Y2.Z2.
    These guest systems are installed on Red Hat Virtualization 4.2. All systems have 8 vCPU's and 32GB of RAM. No memory or CPU over commitment is being used.
    
    Cluster details:
      3 MASTERS.
      3 ETCD NODES.
      3 INFRA NODES.
      20 APP NODES.
      50 PROJECTS.
      200 SERVICES.
      400 PODS.
    
    Maintenance Window Information:
       - Date - Sunday, July 22nd
       - Time frame - 6 hours
       - Timezone - CEST
       - Start Time - 08:00 AM UTC+2
       - End Time - 14:00 PM UTC+2
    
    Primary Contact Information:
       - Name: Jane Doe
       - Email: jane.doe@example.com
       - Phone: +1-123-456-7890
    
    Secondary Contact Information:
      - Name: John Doe
      - Email: john.doe@example.com
      - Phone: +1-123-456-7891
    
  • ケースへの添付:

    must-gather.tar.gz
    sos-report.tar.gz
    

Root Cause

Diagnostic Steps

OpenShift 4

クラスターの一般的なステータスと設定の完全な情報を含む must-gather ログバンドルを収集します。以下の手順、または クラスターに関するデータ収集 のドキュメントを参照してください。

  • must-gather データを保存するディレクトリーに移動します。
  • oc adm must-gather コマンドを実行します。

    $ oc adm must-gather
    
  • 作業ディレクトリーに作成された must-gather ディレクトリーから、圧縮ファイルを作成します。たとえば、Linux オペレーティングシステムを使用するコンピューターで以下のコマンドを実行します。

    $ tar cvaf must-gather.tar.gz must-gather.local.[string]/ 
    

    must-gather-local.[string]/ は、実際のディレクトリー名に置き換え、圧縮ファイルを Red Hat カスタマーポータルのサポートケースに添付してください。

  • リクエストがあった場合に限り、OCP4 内の基盤となる RHCOS ノードから sosreports を収集することもできます。必要に応じて、how to provide a sos report from a RHEL CoreOS OpenShift 4 node を参照してください。

OpenShift 3

OCP 3 で sosreport 適切に収集するには、以下の手順に従うか、こちらのリンク を参照してください。

$ sosreport -e docker -k docker.all=on -k docker.logs=on -k origin.diag=off

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