OSD/ROSA install error related KCS article list
Environment
- Red Hat OpenShift Service on AWS (ROSA)
- 4
- Red Hat OpenShift Dedicated (OSD)
- 4
Issue
- An OSD/ROSA cluster installation has failed
- An OSD/ROSA installation error code needs to be translated
Resolution
This list of KCS articles details errors that can occasionally be experienced during the installation of a ROSA cluster. Note that the list is incomplete and may be added to over time.
Credentials, permissions and roles
- How to check the permissions for AWS roles needed for ROSA STS clusters?
- CLUSTERS-MGMT-400: AWSCredsNotOSDCCSAdmin
- ROSA installation fails with CLUSTERS-MGMT-400 and error: Failed to get list of available aws cloud regions
- Error 403 due to missing iamgetpolicy in ocm-role policy
- OCM3031: ErrorDeletingIAMRole
- OCM3033: AWSInsufficientPermissions
Limit, capacity and quota
- OCM3008: AWSAPIRateLimitExceeded
- OCM3013: AWSVPCLimitExceeded
- OCM3014: S3BucketsLimitExceeded
- OCM3019: AWSNATGatewayLimitExceeded
- OCM3036: LoadBalancerLimitExceeded
- OCM3042: AWSEC2QuotaExceeded
- OCM3052: AWSInsufficientCapacity
Network
Route 53
Subnet
Verification
Unknown error
Root Cause
Under certain circumstances the ROSA installation may fail with an error code.
Diagnostic Steps
Check the error code and message received against the list of articles. The installation log may be checked to obtain a failure code or message if necessary.
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.
Comments