Cluster installation failed with error code OCM3014: S3BucketsLimitExceeded

Solution Verified - Updated -

Environment

  • Red Hat Openshift Container Platform (OCP 4)
  • Red Hat OpenShift Service on AWS (ROSA 4)
  • Red Hat Openshift Dedicated 4 (OSD 4)

Issue

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  • Cluster installation failed with error code OCM3014: S3BucketsLimitExceeded
  • Following error log is observed in the install logs:
level=error msg="Error: Error creating S3 bucket: TooManyBuckets: You have attempted to create more buckets than allowed"

Resolution

The reason behind this error is that you've reached the quota for the number of S3 buckets. You can clean unused S3 buckets to reclaim quota or request a quota increase from AWS and try again.

Option A : Request a quota increase (Recommended)

You can request a quota increase using Service Quotas and AWS Support Center. Increases are not granted immediately. It might take a couple of days for your increase to become effective.

How to request a quota increase?

To request a service quota increase:

  1. Sign in to the AWS Management Console and open the Service Quotas console at here

  2. In the navigation pane, choose AWS services.

  3. Choose an AWS service from the list, or type the name of the service in the search box.

  4. If the quota is adjustable, you can choose the button or the name, and then choose Request quota increase.

  5. For Change quota value, enter the new value. The new value must be greater than the current value.

  6. Choose Request.

To view any pending or recently resolved requests, choose Dashboard from the navigation pane. For pending requests, choose the status of the request to open the request receipt. The initial status of a request is Pending. After the status changes to Quota requested, you'll see the case number with AWS Support. Choose the case number to open the ticket for your request.

After the request is resolved, the Applied quota value for the quota is set to the new value.

Option B: Clean unused S3 buckets

You can only delete buckets that don't have any objects in them. Make sure the bucket is empty.

To delete an S3 bucket:
  1. Sign in to the AWS Management Console and open the Amazon S3 console at here

  2. In the Buckets list, select the option next to the name of the bucket that you want to delete, and then choose Delete at the top of the page.

  3. On the Delete bucket page, confirm that you want to delete the bucket by entering the bucket name into the text field, and then choose Delete bucket.

  4. To verify that you've deleted the bucket, open the Buckets list and enter the name of the bucket that you deleted. If the bucket can't be found, your deletion was successful.

Note: After you empty a bucket, it cannot be undone.

Root Cause

AWS account has default quotas, formerly referred to as limits, for each AWS service. If the quota for a service exceeds its limit, the customer has to request a quota increase from AWS (Recommended) or they can choose to delete unused objects and reclaim quota.

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