Cluster installation failed due to NatGatewayLimitExceeded
Environment
- Red Hat OpenShift Service on AWS (ROSA)
Issue
Cluster installation is failing due to the following error - "Error creating NAT Gateway: NatGatewayLimitExceeded: Performing this operation would exceed the limit of 5 NAT gateways"
Resolution
The reason behind this error is that you've reached the quota for the number of NAT gateways for that Availability Zone.
If you've reached the NAT gateway quota for your account, you can do one of the following:
-
Request an increase in the “NAT gateways per Availability Zone quota” using the Service Quotas console (AWS).
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Check the status of your NAT gateway. A status of Pending, Available, or Deleting counts against your quota. If you've recently deleted a NAT gateway, wait a few minutes for the status to go from Deleting to Deleted. Then try creating a new NAT gateway.
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If you do not need your NAT gateway in a specific Availability Zone, try creating a NAT gateway in an Availability Zone where you haven't reached your quota.
Root Cause
NatGatewayLimitExceeded error is thrown when the quota for the number of NAT gateways for an Availability Zone is exhausted.
Diagnostic Steps
Check the cluster installation logs for detailed error message.
rosa logs install --cluster=<cluster_name> | <cluster_id> [arguments]
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