Cluster installation failed with error code OCM3052: AWSInsufficientCapacity
Environment
- Red Hat Openshift Container Platform (OCP 4)
- Red Hat OpenShift Service on AWS (ROSA 4)
- Red Hat Openshift Dedicated 4 (OSD 4)
Issue
- Cluster installation failed with error code OCM3052 AWSInsufficientCapacity
- A log similar to the following error log is displayed in the install logs:
level=error msg="Error: Error launching source instance: InsufficientInstanceCapacity: We currently do not have sufficient m5.2xlarge capacity in the Availability Zone you requested (eu-south-1b). Our system will be working on provisioning additional capacity. You can currently get m5.2xlarge capacity by not specifying an Availability Zone in your request or choosing eu-south-1a, eu-south-1c."
Resolution
Error Code “AWSInsufficientCapacity” represents that AWS has run out of capacity for a particular availability zone requested by the customer. Our advice to the customer is to try again later or select a different AWS Region or different Availability Zone(s).
Root Cause
This issue occurs when AWS runs out of capacity in a particular Availability Zone requested by the customer.
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