Translated message

A translation of this page exists in English.

JBoss Enterprise Application Platform (EAP) 6 でサポートされる構成

JBoss® Enterprise Application Platform (JBoss EAP) のすべてのリリースは、主要なオペレーティングシステム、Java™ 仮想マシン (JVM)、データベースのさまざまな組み合わせについてテストされ、サポートされています。 Red Hat は、サポートされる構成とテスト済みの統合に対して、本番稼働サポートと開発サポートの両方をお客様のサブスクリプション契約に従って提供します。サポートは、物理環境と仮想環境の両方で提供されます。[1]

サポートされる構成

サポートされる構成で実行するには、以下の Technology Compatibility Kit (TCK) 認定の実装のいずれか、およびその実装でサポートされるオペレーティングシステムのいずれかで、EAP を実行する必要があります。 Red Hat のプラットフォーム互換性の検証は、TCK に依存しています。

Java 仮想マシン バージョン
OpenJDK[2] 1.6
1.7
1.8** 6.4.1 アップデートおよびそれ以降のバージョンでのみサポート
Oracle JDK 1.6
1.7
1.8** 6.3.3 アップデートおよびそれ以降のバージョンでのみサポート
IBM JDK 1.6
1.7
1.8** 6.3.3 アップデートおよびそれ以降のバージョンでのみサポート
HP JDK[3] 1.7
Azul Zing JDK 1.6
1.7
1.8
Azul Zulu 1.6
1.7
1.8

テスト済みの構成

以下のテスト済みの構成に対して、幅広いプラットフォームテストが実施されています。

オペレーティングシステム チップセットアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 7 (最新アップデート) x86_64 Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x
IBM JDK 1.6.x
IBM JDK 1.7.x
IBM JDK 1.8.x
OpenJDK 1.6.x
OpenJDK 1.7.x
OpenJDK 1.8.x
Red Hat Enterprise Linux 7 (最新アップデート) PPC IBM JDK 1.6.x
IBM JDK 1.7.x
IBM JDK 1.8.x
Red Hat Enterprise Linux 6 (最新アップデート) x86
x86_64
Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x
IBM JDK 1.6.x
IBM JDK 1.7.x
IBM JDK 1.8.x
OpenJDK 1.6.x
OpenJDK 1.7.x
OpenJDK 1.8.x
Azul Zulu 1.7.x
Red Hat Enterprise Linux 6.5 (最新アップデート) PPC IBM JDK 1.6.x
IBM JDK 1.7.x
IBM JDK 1.8.x
Microsoft Windows Server 2012 R2 x86_64 Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x
Microsoft Windows Server 2008 x86
x86_64
Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x
Azul Zulu 1.7.x
Microsoft Windows Server 2008 R2 x86_64 Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x
Azul Zulu 1.7.x
Oracle Solaris 10 x86
x86_64
SPARC64
Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x** x86 を除く
Oracle Solaris 11 x86
x86_64
SPARC64
Oracle JDK 1.6.x
Oracle JDK 1.7.x
Oracle JDK 1.8.x* x86 を除く
HP-UX 11v3 Itanium 64 HP JDK 1.7.x

テスト済みのインテグレーション

テスト済みのインテグレーションとは、特別にテストされたインテグレーションテクノロジーの定義済みセットを指し、JBoss Enterprise Middleware のお客様が使用している最も一般的な組み合わせを表します。これらのインテグレーションについて、Red Hat は直接または認定パートナーを通じて、製品リリースプロセスの一環としてさまざまなプラットフォームテストを実施しています。このテストプロセスの過程で確認された問題は、各 JBoss EAP リリースのリリースノートに明記されています。このテスト済みインテグレーションのリストは、随時追加されます。

Red Hat は、お客様のサブスクリプション契約に応じて、テスト済みインテグレーションに対して実稼働サポートと開発サポートの両方を提供します。同じメジャーバージョンであればテスト済みのバージョン以降もサポートされます。同じメジャーバージョンとなるテスト済みインテグレーションの以前のバージョンは、商業的に合理的な範囲でサポートされます。

最新の JBoss EAP 6 リリースの一環として、以下のデータベースおよびデータベースドライバーがテストされました。

データベース JDBC ドライバー
IBM DB2 9.7 IBM DB2 JDBC Universal Driver Architecture 4
IBM DB2 10.1 IBM DB2 JDBC Universal Driver Architecture 4
IBM DB2 10.5 IBM DB2 JDBC Universal Driver Architecture 4
Oracle 11g R1 Oracle JDBC Driver v11
Oracle 11g R1 RAC Oracle JDBC Driver v11
Oracle 11g R2 Oracle JDBC Driver v11
Oracle 11g R2 RAC Oracle JDBC Driver v11
Oracle 12c Oracle JDBC Driver v12
MySQL 5.7 MySQL Connector/J 5
MySQL 5.5 MySQL Connector/J 5
Microsoft SQL Server 2014 Microsoft SQL Server JDBC Driver 4
Microsoft SQL Server 2012 SP2 Microsoft SQL Server JDBC Driver 4
Microsoft SQL Server 2008 R2 SP2 Microsoft SQL Server JDBC Driver 4
PostgreSQL 9.3 JDBC4 Postgresql Driver、バージョン 9
PostgreSQL 9.2 JDBC4 Postgresql Driver、バージョン 9
Sybase ASE 15.7 Sybase jConnect JDBC driver v7
Enterprise DB Postgres Plus Advanced Server 9.3 Postgres Plus Advanced Server Driver 9.3
Enterprise DB Postgres Plus Advanced Server 9.2 Postgres Plus Advanced Server Driver 9.2
FUJITSU Integrated System HA Database Ready SX1 Open SQL Client V1.0、JDBC4 Driver
FUJITSU Software Symfoware Server V12.0.0 Symfoware Server Client V12.0.0 (Open SQL、JDBC4 Driver)
FUJITSU Software Enterprise Postgres V9.2 Enterprise Postgres Client V9.2 (JDBC4 Driver)

最新の JBoss EAP 6 リリースの一環として、以下の Web サーバーおよびコネクターがテストされました。

Web サーバー バージョン オペレーティングシステム コネクター 注記
JBoss Core Service Apache HTTP Server
(Apache 2.4.23 ベース
2.4.23 Red Hat Enterprise Linux 7 (x86_64)
Red Hat Enterprise Linux 6 (x86、x86_64)
Solaris 11 (x86、x86_64、SPARC64)
Solaris 10 (x86、x86_64、SPARC64)
Windows Server 2012 R2 (x86_64)
mod_cluster 1.3.5 Final
mod_jk 1.2.41
EAP 6.4.4 以降が必要
JBoss Web Server
(Apache 2.4.6 ベース)
3.0.2 (2015 年 12 月) Red Hat Enterprise Linux 7 (x86_64)
Red Hat Enterprise Linux 6 (x86、x86_64)
Solaris 11 (x86、x86_64、SPARC64)
Solaris 10 (x86、x86_64、SPARC64)
Windows Server 2012 R2 (x86_64)
mod_cluster 1.3.1 Final
mod_jk 1.2.40
EAP 6.4.4 以降が必要
Application Platform 6.4.0 Apache Web Server
(Apache 2.2.26 ベース)
6.4.0 Red Hat Enterprise Linux 7 (x86_64、PPC)
Red Hat Enterprise Linux 6 (x86、x86_64、PPC)
Solaris 11 (x86、x86_64、SPARC64)
Solaris 10 (x86、x86_64、SPARC64)
Windows Server 2012 (x86_64)
Windows Server 2008 (x86、x86_64)
Windows Server 2008 R2 (x86_64)
mod_cluster 1.2.11 Final
mod_jk 1.2.40
該当なし
JBoss Enterprise Web Server
(Apache 2.2.26 ベース)
2.1.0 (2014 年 8 月) Red Hat Enterprise Linux 6 (x86、x86_64)
Solaris 11 (x86、x86_64、SPARC64)
Solaris 10 (x86、x86_64、SPARC64)
Windows Server 2012 (x86_64)
Windows Server 2008 (x86、x86_64)
Windows Server 2008 R2 (x86_64)
mod_cluster 1.2.11 Final
mod_jk 1.2.40
該当なし
Apache Web Server 2.2.15 Red Hat Enterprise Linux 6 (x86、x86_64、PPC) mod_cluster 1.2.11 Final
mod_jk 1.2.40
Microsoft IIS 7.0 Windows Server 2008 (x86、x86_64) isapi_redirect 1.2.40 該当なし
Microsoft IIS 7.5 Windows Server 2008 R2 (x86_64) isapi_redirect 1.2.40 該当なし
Microsoft IIS 8.5 Windows Server 2012 R2 (x86_64) isapi_redirect 1.2.40 該当なし
Oracle iPlanet Web Server 7.0.15 Solaris 11 (SPARC64) nsapi_redirector 1.2.40 該当なし
Oracle iPlanet Web Server 7.0.15 Solaris 11 (x86、x86_64)
Solaris 10 (x86、x86_64)
nsapi_redirector 1.2.40 該当なし
Oracle iPlanet Web Server 1.0.15 Solaris 10 (SPARC64) nsapi_redirector 1.2.40 該当なし
Apache Web Server 2.2.15 HP-UX 11v3 (Itanium 64) mod_cluster 1.2.9 Final
mod_jk 1.2.40

JBoss EAP 6 とテストされた外部 JMS プロバイダーは次のとおりです。

JMS プロバイダー リソースアダプター
Red Hat JBoss A-MQ 6.1[4] Red Hat JBoss A-MQ JCA Adapter
IBM WebSphere MQ v7.5 IBM WebSphere MQ JCA Adapter v7.5

[1] Red Hat では、サポートされる環境をお客様が引き続き利用されることを前提としています。ベンダーが JVM、オペレーティングシステム、データベースなどのサポートを終了した場合 (特定のバージョンのサポートを含む) は、Red Hat が提供するサポートが限定される可能性があります。サポートを継続するには、サポートされる環境における問題再現をお客様にお願いする場合があります。

[2] Red Hat による OpenJDK のサポートは、Red Hat 提供の OpenJDK ビルドに限定されます。

[3] HP JDK のサポートは EAP バージョン 6.1 で追加されました。 EAP 6.x の以前のバージョンは HP JDK で認定されていません。

[4] A-MQ とのインテグレーションのサポートは、EAP バージョン 6.1.1 以降に限定されます。

本書への変更の一覧は、「JBoss EAP 6 Supported Configurations Errata」を参照してください。