What Releases of Red Hat Ansible Engine are Compatible with Red Hat Ansible Tower?

Updated -

This table denotes what releases of Ansible Engine can be used with certain versions of Ansible Tower. Note that these Ansible Engine and Ansible Tower releases may be end of life, even if they can coexist.

Ansible Engine Ansible Tower 3.4 Ansible Tower 3.5 Ansible Tower 3.6 Ansible Tower 3.7
2.3 y y y y
2.4 y y y y
2.5 y y y y
2.6 x x y y
2.7 x x x1 y
2.8 x x2 x x
2.9 x x x

Key
x: Fully supported
y: Only supported in a custom virtual environment for playbook execution. Not supported for Tower installation or other usage. Note that these versions may be end-of-life for support.

Note on prior releases: Ansible Tower 3.0 supported Ansible 1.9 through 2.3. Ansible Tower 3.1 supported Ansible 2.1 through 2.4. Ansible Tower 3.2 supported Ansible 2.2 through 2.6. Ansible Tower 3.3 supported Ansible 2.3 through 2.7.


  1. Ansible 2.8 or later and RHEL python-cryptography required to configure SSL for RabbitMQ 

  2. When running on Red Hat Enterprise Linux 8, Ansible 2.8 is required.