How to register and subscribe a system offline to the Red Hat Customer Portal?
Environment
- Red Hat Enterprise Linux
- Red Hat Subscription Management (RHSM)
- Red Hat Customer Portal
Issue
- Why does the Offline system need to be registered with the Red Hat Customer portal?
- How to register a new Offline Red Hat Enterprise Linux system to the Customer Portal?
- How to register a system that is not connected to the internet?
- How to register a disconnected system?
- How to manually register a system to the Customer Portal?
- How to create a system profile in Red Hat Subscription Management?
- Subscription-manager list commands shows status as "Unknown" after registering systems offline
- Subscription-manager status displays error message "Unknown" even after importing the correct certificates
Resolution
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The offline registration feature of an "air-gapped" system is deprecated and no longer available with the transition to Simple Content Access
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If a system is unable to register to subscription.rhsm.redhat.com to register, Red Hat advises users to implement Red Hat Satellite.
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For reporting purpose, Red Hat Discovery can be used.
Root Cause
- With the transition of registration workflow from the legacy entitlement method to the new Simple Content Access method, the functionality of registering systems offline as described in KCS 3121571 has been deprecated.
- For SCA enabled accounts, once after registration, the entitlement certificates are generated under /etc/pki/entitlement directory.
What are Entitlement Certificates in Red Hat Subscription Management?
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