Translated message

A translation of this page exists in English.

Red Hat Enterprise Linux 仮想マシンを MS Hyper-V に移行した後、システムが起動に失敗して dracut モードに陥る

Solution In Progress - Updated -

Issue

  • 1 つのハイパーバイザー (VMWare ESX など) から Red Hat 仮想マシンの Hyper-V に移行すると、システムが dracut でスタックしたり、以下のようなメッセージが表示されて root ファイルシステムを見つけられなくなったりして、can't boot 問題が発生します。
/dev/mapper/rhel-root does not exist
end_request: I/O error
blk_update_request: I/O
dracut:/#

Environment

  • Red Hat Enterprise Linux 6、7、8、9
    • Hyper-V

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content