Red Hat Enterprise Linux 仮想マシンを MS Hyper-V に移行した後、システムが起動に失敗して dracut モードに陥る
Issue
- 1 つのハイパーバイザー (VMWare
ESXなど) から Red Hat 仮想マシンのHyper-Vに移行すると、システムがdracutでスタックしたり、以下のようなメッセージが表示されて root ファイルシステムを見つけられなくなったりして、can't boot問題が発生します。
/dev/mapper/rhel-root does not exist
end_request: I/O error
blk_update_request: I/O
dracut:/#
Environment
- Red Hat Enterprise Linux 6、7、8、9
- Hyper-V
Subscriber exclusive content
A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.