Translated message

A translation of this page exists in English.

Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

Red Hat および JBoss は、Apache、mod_jk、mod_proxy、または mod_cluster にサポートを提供しますか?

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux (RHEL)
  • Red Hat JBoss Enterprise Application Platform (EAP)
  • Red Hat JBoss Enterprise Web Server (EWS)
  • Solaris
  • Linux
  • Windows

Issue

  • 以下の完全サポートを含む製品またはエンタイトルメントは Red Hat で提供されていますか?
    • Apache httpd
    • mod_jk
    • mod_proxy
    • mod_cluster
  • JBoss EAP では、どの負荷分散、プロキシー、または web サーバーのソリューションがサポートされますか?
  • ロードバランサーは JBoss と互換性はありませんか?
    • 互換性がない場合は、どのハードウェアのロードバランサーを使用する必要がありますか?
  • 以下のサードーパーティのロードバランサーはサポートされていますか?
    • BIG-IP (F5)
    • ACE (Cisco)
    • AppDirector (radware)
  • Apache httpd-2.2.15 RHEL6 で mod_jk を使用することは JBoss EAP 4.3.0 でサポートされますか?
  • "Red Hat Enterprise Linux Server release 6.4" を実行するサーバーで mod_jk はサポートされますか? それとも別のライセンスを購入する必要はありますか?
  • mod_jk の最新バージョンは? mod_jk は今後も開発されますか? または廃止されますか?
  • Tomcat 6.0.24 で Apache httpd-2.2.15 と共に mod_jk を使用することは RHEL サブスクリプションでサポートされていますか?
  • JBoss EAP で IBM HTTP Webserver と共に mod_jk を使用することはサポートされますか?

Resolution

  • Red Hat では、サードパーティー製ハードウェアのロードバランサーに対するカスタマーサポートは提供していません。

    • サードパーティーのロードバランサーについて質問がある場合は、ハードウェアベンダーに問い合わせることが推奨されます。
  • 各製品でサポートされているものについては、以下にあげるリソースセクションと、関連リンクを参照してください。

  • RHEL、JBoss EWS、または EAP 6 Apache Web Server に同梱される Apache httpd バージョンを実行することだけが公式にサポートされます。

    • また、製品の組み合わせによっては、mod_cluster など、特定の製品バージョンや組み合わせが必要な場合もあります。
    • カスタムビルドの Apache httpd やコミュニティ版の Apache httpd はサポート対象外であり、サポートは提供されないことに注意してください。
  • Red Hat's load balancer configuration app を使用すれば mod_jk、mod_proxy、または mod_cluster への最適な設定を生成できます。

mod_* サポートに関連する注意:

  • mod_proxy は、同梱する Apache 関連の各製品で一般的に利用可能、またはビルトインされます。
  • EAP 5 の場合、mod_cluster は現在 EWS + EAP にのみに同梱されており、RHEL 6 の Apache でサポートされています。
    • 以前のバージョンの RHEL では Apache 2.2.8 以降が提供されておらず、mod_cluster が 2.2.8 以前のバージョンの httpd とでは動作しない問題が発生しています。
    • mod_cluster は、RHEL6 以降の httpd バージョンでテストされサポートされています。
  • mod_jk は、EWS + EAP および RHEL 6 でサポートされています。
  • RHEL 6 と RHEL エンタイトルメントで mod_jk を使用する際にサポートを受けるには、EAP のエンタイトルメントが必要になります。

    • mod_jk は RHEL では同梱されず、EAP ネイティブダウンロードに同梱されているものが必要か、RHN で EAP チャンネルから mod_jk パッケージを取得する必要があります。
  • Apache HTTPD バンドル (EWS の httpd 製品と同様に、mod_proxy/jk/cluster から EAP 6 サーバーの負荷分散するためにテストされサポートされる) は、JBoss EAP 6 で異なるダウンロードとして含まれます。

    • この EAP 6 Apache サーバーのサポートは、既存の EAP エンタイトルメントによってカバーされています。
    • EAP 4 および 5 と、6 でサポートされる構成には少し異なる点があります。
  • 各バージョンでサポートされる構成は以下を参照してください。

以下の表で、どの httpd loadbalancer モジュールが、どの EAP および httpd の組み合わせをサポートするかを示しています。

EAP 4 EAP 5 EAP 6
RHEL 5 の 2.2.3 proxy proxy proxy+jk
RHEL 6 の 2.2.15 proxy proxy+jk+cluster proxy+jk+cluster
EWS proxy+jk proxy+jk+cluster proxy+jk+cluster
EAP 6 HTTP Server N/A N/A proxy+jk+cluster

ご不明な点がある場合は、営業チームまたはサポートチームにお問い合わせください。

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.