3.2. Deprecated Features

The following table describes deprecated features to be removed in a future version of Red Hat Virtualization.

Table 3.2. Deprecated Features

Deprecated FeatureDetails

Version 3 REST API

Version 3 of the REST API is no longer supported. Use the version 4 REST API.

Version 3 SDKs

Version 3 of the SDKs for Java, Python, and Ruby are no longer supported. Use the version 4 SDK for Java, Python, or Ruby.

RHEVM Shell

Red Hat Virtualization’s specialized command line interface is no longer supported. Use the version 4 SDK for Java, Python, or Ruby, or the version 4 REST API.

Export Domains

Use a data domain. Migrate data domains between data centers and import the virtual machines into the new data center.

In Red Hat Virtualization 4.3, some tasks may still require the export domain.

ISO domains

Use a data domain. Upload images to data domains.

In Red Hat Virtualization 4.3, some tasks may still require the ISO domain.

Iptables

Use the firewalld service.

Conroe, Penryn, Opteron G1, Opteron G2, and Opteron G3 CPU types

Use newer CPU types.

IBRS CPU types

Use newer fixes.

3.6 and 4.0 cluster compatibility versions

Use a newer cluster compatibility version. Upgrade the compatibility version of existing clusters.

ovirt-guest-agent

The ovirt-guest-agent project is no longer supported. Use qemu-guest-agent version 2.12.0 or later.

cockpit-machines-ovirt

The cockpit-machines-ovirt package is not included in Red Hat Enterprise Linux 8 and will not be supported in Red Hat Virtualization Host 4.4. Use the Administration Portal.