Translated message

A translation of this page exists in English.

如何在 RHOCP4 中重新部署/续订过期的默认入口证书?

Solution In Progress - Updated -

Issue

  • 没有提示默认入口证书即将过期的警报。
  • 如何续订或重新生成过期的默认入口证书。
  • 由于默认入口证书已过期,OpenShift 4 Web 控制台无法访问,并显示错误 NET::ERR_CERT_DATE_INVALID。
  • authentication 集群 Operator 不可用并降级,并带有以下信息:

    OAuthServerRouteEndpointAccessibleController_EndpointUnavailable
    
    OAuthServerRouteEndpointAccessibleController_SyncError::RouterCertsDomainValidationController_SyncError::RouterCerts_InvalidServerCertRouterCerts
    
    OAuthServerRouteEndpointAccessibleControllerDegraded: Get "https://oauth-openshift.apps.example.com/healthz": x509: certificate has expired or is not yet valid:current time YYYY-MM-DDTHH:MM:SSZ is after YYYY-MM-DDTHH:MM:SSZ
    
    RouterCertsDegraded: secret/v4-0-config-system-router-certs.spec.data[apps.example.com] -n openshift-authentication: certificate could not validate route hostname oauth-openshift.apps.example.com: x509: certificate has expired or is not yet valid: current time YYYY-MM-DDTHH:MM:SSZ is after YYYY-MM-DDTHH:MM:SSZ
    
  • 由于 certificate has expired,无法使用 oc CLI 登录:

    $ oc login -u kubeadmin https://api.cluster.example.com:6443
    error: x509: certificate has expired or is not yet valid: current time YYYY-MM-DDTHH:MM:SSZ is after YYYY-MM-DDTHH:MM:SSZ
    

Environment

  • Red Hat OpenShift Container Platform (RHOCP)
    • 4
  • 默认入口 (Ingress) 证书

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content