systemd cause "user-runtime-dir@<USERID>.service: Failed with result 'start-limit-hit'." error
Issue
-
When executing commands with
cron,sshd, orsu,systemdsometimes cause error logs like this:Nov 30 10:05:01 rhel8 systemd[1]: user-runtime-dir@<USERID>.service: Failed with result 'start-limit-hit'. Nov 30 10:05:01 rhel8 systemd[1]: Failed to start User runtime directory /run/user/<USERID>. Nov 30 10:05:01 rhel8 systemd[1]: Dependency failed for User Manager for UID <USERID>.
Environment
- Red Hat Enterprise Linux 8 and later
- systemd
cron,su,sudoorsshdsessions
Subscriber exclusive content
A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.