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ROSA のオフラインアクセストークンの取得を試みると、"User has exceeded the maximum number of offline sessions" というメッセージが表示される

Solution Verified - Updated -

Environment

Red Hat OpenShift Service on AWS (ROSA)
Red Hat OpenShift Cluster Manager

Issue

https://cloud.redhat.com/openshift/token/rosa からオフラインアクセストークンを取得しようとすると、ページに以下のエラーが表示されます。

{"error":"offline_session_limit_exceeded","error_description":"User has exceeded the maximum number of offline sessions.  Please visit the session management page for more details."}

Resolution

Red Hat アカウントの https://sso.redhat.com/auth/realms/redhat-external/account/applications ページで、古いオフラインアクセストークンを取り消します。

Root Cause

トークンの有効期間は長いため、生成したら後で使用できるようにローカルに保存する必要があります。

https://cloud.redhat.com/openshift/token/rosa からオフラインアクセストークンを繰り返し取得しようとすると、生成されたトークンが多すぎるため、最終的にはこの制限に達します。

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