OpenShift Data Foundation managed service StorageSystems instance ocs-storagecluster-storagesystem Condition: "onboarding ticket is not valid. onboarding ticket is expired"

Solution Verified - Updated -

Environment

  • Red Hat OpenShift on AWS (ROSA)
    • 4.10
  • OpenShift Data Foundation Managed Service
    • 4.10

Issue

When installing Red Hat OpenShift Data Foundation Managed Service with Red Hat Hybrid Cloud Console (OCM web console) or via rosa cli on ROSA 4.x, the following event messages are shown:

  • OpenShift Data Foundation managed service install failed
  • Check StorageSystems instance ocs-storagecluster-storagesystem Condition and found the error
  conditions:
  - lastHeartbeatTime: "2023-03-07T14:37:19Z"
    lastTransitionTime: "2023-03-06T18:18:34Z"
    message: 'Error while reconciling: rpc error: code = InvalidArgument desc = onboarding
      ticket is not valid. onboarding ticket f74a587b-xxxx-xxxx-xxxx-3c6259e151e8 is expired'

Resolution

  1. Complete uninstall the OpenShift Data Foundation Managed Service.
    Pre-requisites:

    • Access to the latest version of ROSA command-line interface (CLI)
    • Delete the PVCs after ensuring that no applications are consuming these PVCs using the following storage classes provided by OpenShift Data Foundation Managed Service
      • ocs-storagecluster-ceph-rbd
      • ocs-storagecluster-cephfs
    • Delete volume snapshots after removing any resources that used the snapshots.

    Procedure:

    • To uninstall the consumer add-on, run the following command from the ROSA CLI:

      $ rosa uninstall addon --cluster=<cluster-name> ocs-consumer
      
  2. Generate a new onboarding ticket by following the document.
    Prerequisites:

    • An RSA public-private key pair.

    Procedure:

    • To create the onboarding ticket, download the ticketgen script from the GIT repository.

      $ wget https://raw.githubusercontent.com/red-hat-storage/ocs-operator/main/hack/ticketgen/ticketgen.sh
      
    • Make the ticketgen script executable.

      $ chmod +x ./ticketgen.sh
      
    • Execute the ticketgen script. The output of this command is an encrypted token.

      $ ./ticketgen.sh <private-key>
      
  3. Reinstall Red Hat OpenShift Data Foundation Managed Service by following the document.
    Prerequisites:

    • A ROSA cluster installed within the same Virtual Private Cloud (VPC) as that of the OpenShift Data Foundation provider.
    • The consumer onboarding ticket.
    • Storage provider API endpoint details.
    • Access to the latest version of ROSA command-line interface (CLI).

    Procedure:

    • Install the consumer add-on using the following command. After you run the command, you get an interactive prompt. Add the information asked in the prompt.

      Important: 
      When adding the storage provider API endpoint information, append the API port number (31659) to the IP address.
      For example, if the IP address is 10.10.xxx.xx, append 31659 to this address as 10.10.xxx.xx:31659.
      
      $ rosa install addon --cluster=<cluster-name> ocs-consumer
      

Root Cause

Onboarding ticket can not be reused.

You must use a new onboarding ticket every time you attempt to install the consumer add-on.

Diagnostic Steps

oc get storageclusters.ocs.openshift.io ocs-storagecluster -o yaml

Check conditions message

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