In RHOCP v4.7.0 white blank page is seen when accessing web console

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Container Platform
    • 4.7.0

Issue

  • Whenever Red Hat OpenShift's web console is accessed through an unsupported browser or some outdated browser version, white blank page is seen.

Resolution

  • Only use supported browser versions and variants mentioned in Tested integrations for 4.x.
  • The bug is fixed in RHOCP v4.8.2 ERRATA. Below error message can be expected instead of blank screen:
Internet Explorer 11 and earlier are not supported, and the ocp console will not function with your current browser. Please use a supported browser such as the latest version of Google Chrome, Mozilla Firefox, Microsoft Edge, or Safari. The current Firefox ESR(Extended Support Release) is also supported. To see the browsers we test, refer to the OpenShift Container Platform 4.x Tested Integrations (for x86_x64). 

Root Cause

  • This issue is tracked in Bug 1905627 and the Engineering team is working on adding an error message instead of blank screen.

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