Why dracut fails to create initrd image with error network-legacy no module found

Solution Verified - Updated -

Issue

  • Unable to update to new kernel version with yum as transaction fails with:
dracut: dracut module 'network-legacy' cannot be found or installed.
warning: %posttrans(kernel-core-4.18.0-xx.xx.el8_3.x86_64) scriptlet failed, exit status 1

Error in POSTTRANS scriptlet in rpm package kernel-core

Environment

  • Red Hat Enterprise Linux 8

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content