OpenShift 4 upgrade fails due to "the image may not be safe"

Solution Verified - Updated -

Issue

  • OpenShift 4 upgrade is failing due to:
oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.2     True        True          4h24m   Unable to apply 4.2.4: the image may not be safe to use
  • Upgrade to 4.2.13 fails

Environment

  • Red Hat OpenShift Container Platform
    • 4.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In