- Red Hat Enterprise Linux 5.1 and later.
- Red Hat Network (RHN) Hosted.
- Red Hat Satellite.
- yum-security-1.0.4-3.el5-noarch and yum-3.2.22-26.el5 or higher
- yum update --security fails with missing dependency errors
below is an example;
Error: Unresolvable requirement /etc/pam.d/system-auth for ppp-2.4.4-1.el5.x86_64 (installed) Error: Unresolvable requirement libX11-devel for pango-devel-1.14.9-8.el5.x86_64 (installed) Error: Unresolvable requirement pam >= 0.66-12 for coreutils-5.97-12.1.el5.x86_64 (installed) Error: Unresolvable requirement pam >= 0.66-5 for SysVinit-2.86-14.x86_64 (installed)
- Confirm that latest yum and yum-security packages are installed on system.
# yum update yum
# yum update yum-security
# rm -rf /var/cache/yum/*
Now try to update security patches on system using
# yum update --security
- Older version of
yum-securitypackages were installed on system along with latest yum package.
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.