yum update fails with dependency issues on rhn-*.noarch packages

Solution Verified - Updated -

Issue

  • yum update fails with

    Error: Package: rhn-check-2.0.2-21.el7.noarch (rhel-7-server-rpms)
           Requires: rhn-client-tools = 2.0.2-21.el7
           Removing: rhn-client-tools-2.0.2-17.el7.noarch (@anaconda/7.4)
               rhn-client-tools = 2.0.2-17.el7
           Updated By: rhn-client-tools-2.0.2-24.el7.x86_64 (rhel-7-server-rpms)
    

Environment

  • Red Hat Enterprise Linux 7
  • noarch packages of rhn-check, rhn-client-tools, rhn-setup, rhn-setup-gnome are installed
# rpm -qa | grep ^rhn-.*noarch
rhn-check-2.0.2-17.el7.noarch
rhn-client-tools-2.0.2-17.el7.noarch
rhn-setup-2.0.2-17.el7.noarch
rhn-setup-gnome-2.0.2-17.el7.noarch

Note: rhn-setup-gnome is a part of the GNOME group and may or may not be installed on your system. This issue occurs with or without that package.

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In