yum update fails with "initscripts conflicts with redhat-release-server-7.2-9.el7.x86_64" error.

Solution Verified - Updated -

Issue

  • yum update fails with initscripts conflicts with redhat-release-server-7.2-9.el7.x86_64 error.

    # yum update
    Loaded plugins: changelog, product-id, rhnplugin, search-disabled-repos, subscription-manager, tmprepo, verify, versionlock
    This system is receiving updates from RHN Classic or Red Hat Satellite.
    Resolving Dependencies
    --> Running transaction check
    ---> Package initscripts.x86_64 0:9.49.39-1.el7 will be updated
    ---> Package initscripts.x86_64 0:9.49.41-1.el7 will be an update
    --> Processing Conflict: initscripts-9.49.41-1.el7.x86_64 conflicts redhat-release < 7.5-0.11
    --> Finished Dependency Resolution
    Error: initscripts conflicts with redhat-release-server-7.2-9.el7.x86_64
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    
  • Processing Conflict: initscripts-9.49.41-1.el7.x86_64 conflicts redhat-release < 7.5-0.11 error is seen while updating a client system.

Environment

  • Red Hat Enterprise Linux 7.2
  • Red Hat Satellite 5.8

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content