How to install libstdc++ [32 bit ] package on RHEL7 [64 bit] ?

Solution Verified - Updated -

Issue

  • Unable to install libstdc++ on RHEL 7.x
  • Failed dependency error while installing libstdc++
# rpm -ivh libstdc++-4.8.5-25.el7.i686.rpm
error: Failed dependencies:
        ld-linux.so.2 is needed by libstdc++-4.8.5-25.el7.i686
        ld-linux.so.2(GLIBC_2.3) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6 is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.0) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.1) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.1.3) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.2) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.3) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.3.2) is needed by libstdc++-4.8.5-25.el7.i686
        libc.so.6(GLIBC_2.4) is needed by libstdc++-4.8.5-25.el7.i686
        libgcc_s.so.1 is needed by libstdc++-4.8.5-25.el7.i686
        libgcc_s.so.1(GCC_3.0) is needed by libstdc++-4.8.5-25.el7.i686
        libgcc_s.so.1(GCC_3.3) is needed by libstdc++-4.8.5-25.el7.i686
        libgcc_s.so.1(GCC_4.2.0) is needed by libstdc++-4.8.5-25.el7.i686
        libgcc_s.so.1(GLIBC_2.0) is needed by libstdc++-4.8.5-25.el7.i686
        libm.so.6 is needed by libstdc++-4.8.5-25.el7.i686
        libm.so.6(GLIBC_2.0) is needed by libstdc++-4.8.5-25.el7.i686

Environment

  • Red Hat Enterprise Linux 7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In