'subscription-manager list --available --all' returns "No Available subscription pools to list"
Environment
- Red Hat Enterprise Linux
- Red Hat Subscription Management (RHSM)
- Red Hat Customer Portal
Issue
- Getting error
No available subscription pools to list
while listing subscriptions. - System is registered through Red Hat Subscription Management but cannot attach any subscriptions.
- The subscriptions are visible under
Active Subscriptions
section in the Customer Portal, but not listed in CLI.
Resolution
- Purchase more subscriptions or free up existing subscriptions by removing or unregistering unused systems via Customer Portal, as the account doesn't have enough valid subscription to cover the current system.
- If the subscriptions are not getting listed on Customer Portal, open a support case with Red Hat Technical Support to perform re-pooling of the account subscriptions.
-
Re-register the system to clear and refresh old subscription cache/data.
# subscription-manager unregister # subscription-manager clean # subscription-manager register
Root Cause
- The warning message
No Available subscription pools to list
shows that the account doesn't have enough quantity of valid subscription to cover the entire system (CPU/Cores/Sockets). - If the subscription is newly purchased, it may take up sometime for the pool to reflect under Red Hat Subscription Management.
- The subscription-manager related data/cache might be corrupted which needs to be cleaned.
Diagnostic Steps
-
Check for available subscription:
# subscription-manager list --available --all No available subscription pools to list
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