While installing a package, why yum/rpm/up2date command failed with error "/usr/lib/libcpqlsptransport.so.0 is not a symbolic link" ?

Solution Unverified - Updated -

Issue

  • When trying to install a package using yum/rpm/up2date, I am getting error ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link.

  • Why ldconfig complains about /usr/lib/libcpqlsptransport.so.0 ?

Eg:

[root@server1 ~]# yum -y update 

Running Transaction 
Updating  : libgcc                   ##################### [  1/985]/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symboliclink 
Updating  : libgcc                   ##################### [  2/985]/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link 
Updating  : glibc                    ##################### [  3/985]/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link 
Updating  : glibc                    ##################### [  4/985]/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link 

Eg:

[root@server1 ~]# rpm -ivh scli-1.7.3-40.i386.rpm
Preparing... ########################################### [100%]
1:scli ########################################### [100%]
ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link

Eg:

# up2date -u

Fetching Obsoletes list for channel: rhel-x86_64-as-4...
########################################

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
firefox                                 3.6.22              1.el4 x86_64
gstreamer-plugins                       0.8.5               1.EL.4 x86_64
seamonkey                               1.0.9               75.el4 x86_64

Testing package set / solving RPM inter-dependencies...
########################################
firefox-3.6.22-1.el4.x86_64 ########################## Done.
gstreamer-plugins-0.8.5-1.E ########################## Done.
seamonkey-1.0.9-75.el4.x86_ ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:seamonkey              ########################################### [100%]
   2:gstreamer-plugins      ########################################### [100%]
/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link

   3:firefox                ########################################### [100%]
/sbin/ldconfig: /usr/lib/libcpqlsptransport.so.0 is not a symbolic link

Environment

  • Red Hat Enterprise Linux 4,5
  • ldconfig
  • /usr/lib/libcpqlsptransport.so.0
  • up2date
  • yum
  • rpm

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In