How to configure Apache httpd to use PHP from RHSCL (rh-php70 or rh-php56)

Solution Verified - Updated -

Issue

  • How can we connect mod_php7 (libphp7) from Red Hat Software Collections (RHSCL) rh-php70-php to httpd?
  • How can we connect mod_php5 (libphp5) from RHSCL rh-php56-php to httpd?
  • How can we connect mod_php5 (libphp5) from RHSCL php55-php to httpd?
  • How can we connect mod_php5 (libphp5) from RHSCL php54-php to httpd?
  • I would like to know what I need to install and how to configure it so that httpd24 is being used with php56 (or greater) and my .php files are being processed by the Apache Web Server.
  • How to install and configure Apache httpd and PHP 5.6 from RHSCL?

Environment

  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 6
  • httpd or http24 with one of:
    • rh-php72-php
    • rh-php71-php
    • rh-php70-php
    • rh-php56-php
    • php55-php
    • php54-php

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In