How can I use the yum output to solve yum dependency errors?

Solution Verified - Updated -

Issue

  • I use a custom repository and get yum errors, how can I use the yum output to solve the problem?
  • Yum refuses to update packages, reporting a dependency being required, but the dependency is already installed
  • Yum update fails with a "missing dependency" error similar to the following:
Missing Dependency: package1 = 2:4.11 is needed by package 2:package2.i386 (rhel-i386-server-5)

or

Missing Dependency: /lib64/security/pam_loginuid.so is needed by package openssh-server-4.3p2-82.el5.x86_64 (installed)
Error: Missing Dependency: /lib64/security/pam_loginuid.so is needed by package openssh-server-4.3p2-82.el5.x86_64 (installed)
  • Yum refuses to install an update because of an installed package whose dependencies the update would break :
Error: Package: libreport-2.0.9-19.el6.i686 (rhel-6-server-rpms)
           Requires: libreport-python = 2.0.9-19.el6
           Removing: libreport-python-2.0.9-19.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201311111358.x86_64/6.5)
               libreport-python = 2.0.9-19.el6
           Updated By: libreport-python-2.0.9-19.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-19.0.1.el6
           Available: libreport-python-2.0.5-20.el6.x86_64 (rhel-6-server-rpms)
               libreport-python = 2.0.5-20.el6
           Available: libreport-python-2.0.5-20.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.5-20.0.1.el6
           Available: libreport-python-2.0.9-5.el6.x86_64 (rhel-6-server-rpms)
               libreport-python = 2.0.9-5.el6
           Available: libreport-python-2.0.9-5.el6_3.2.x86_64 (rhel-6-server-rpms)
               libreport-python = 2.0.9-5.el6_3.2
           Available: libreport-python-2.0.9-5.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-5.0.1.el6
           Available: libreport-python-2.0.9-5.0.1.el6_3.2.x86_64 (ol6_latest)
               libreport-python = 2.0.9-5.0.1.el6_3.2
           Available: libreport-python-2.0.9-15.el6.x86_64 (rhel-6-server-rpms)
               libreport-python = 2.0.9-15.el6
           Available: libreport-python-2.0.9-15.el6_4.1.x86_64 (rhel-6-server-rpms)
               libreport-python = 2.0.9-15.el6_4.1
           Available: libreport-python-2.0.9-15.0.1.el6.x86_64 (ol6_latest)
               libreport-python = 2.0.9-15.0.1.el6
           Available: libreport-python-2.0.9-15.0.1.el6_4.1.x86_64 (ol6_latest)
               libreport-python = 2.0.9-15.0.1.el6_4.1
  • Yum rejects a trasaction with a check error mentioning previously installed files being incompatible with new ones

Environment

  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Satellite 5.x
  • Red Hat Satellite 6.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In