Translated message

A translation of this page exists in English.

RHOCP4 でノードの証明書を更新または再作成する方法

Solution In Progress - Updated -

Issue

  • 1 つ以上のノードが "NotReady" ステータスで動作していません。
  • Kubelet サービスログには多くのメッセージが表示されます。

    Unable to authenticate the request due to an error: x509: certificate signed by unknown authority
    http: TLS handshake error from 10.173.2.64:43632: no serving certificate available for the kubelet
    
  • ノード証明書が期限切れまたは不一致ですが、保留中の CSR はありません

  • ノード証明書を再デプロイしたり、TLS ブートストラップを実行したりするにはどうすればよいですか?

Environment

  • Red Hat OpenShift Container Platform (RHOCP)
    • 4

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content