Translated message

A translation of this page exists in English.

3PARdata Remote Copy LUN を備えたサーバーでマルチパスのパス障害エラーが多数発生し、起動に失敗する

Solution In Progress - Updated -

Issue

  • 100 を超える 3PARdata Remote Copy LUN を備えたサーバーでマルチパスのパス障害エラーが多数発生し、起動に失敗します。

    Aug 22 11:43:22 testhost multipathd: sdb: mark as failed
    Aug 22 11:43:22 testhost multipathd: mpathap: remaining active paths: 1
    Aug 22 11:43:22 testhost multipathd: sdk: mark as failed
    Aug 22 11:43:22 testhost multipathd: mpathap: Entering recovery mode: max_retries=18
    Aug 22 11:43:22 testhost multipathd: mpathap: remaining active paths: 0
    Aug 22 11:43:22 testhost multipathd: sdn: mark as failed
    Aug 22 11:43:22 testhost multipathd: mpathag: Entering recovery mode: max_retries=18
    Aug 22 11:43:22 testhost multipathd: mpathag: remaining active paths: 0
    Aug 22 11:43:22 testhost multipathd: sdf: mark as failed
    Aug 22 11:43:22 testhost multipathd: mpathbf: Entering recovery mode: max_retries=18
    Aug 22 11:43:22 testhost multipathd: mpathbf: remaining active paths: 0
    Aug 22 11:43:22 testhost multipathd: mpathap: Entering recovery mode: max_retries=18
    [...]
    

    上記のパス障害エラーが発生すると、ブートプロセスがハングします。

  • 上記のエラーとブートプロセスのハングは、サーバーにリモートサイトの 3PAR ストレージコントローラーから割り当てられたアクティブパスと、ローカルサイトからのスタンバイパスがある場合にのみ発生します。

  • "アクティブゴースト" パスは"アクティブレディ" パスより先に検出されるため、ゴーストパスの使用を試みたときに (alua Standby) IO エラーやパス障害が発生します。

Environment

  • Red Hat Enterprise Linux 7
  • device-mapper-multipath
  • Peer Persistence と Remote Copy が設定された 3PARdata LUN
    (リモートサイトの 3PAR ストレージコントローラーから割り当てられたアクティブパスとローカルサイトからのスタンバイパス)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content