Translated message

A translation of this page exists in English.

Warning message

This translation is outdated. For the most up-to-date information, please refer to the English version.

Red Hat JBoss Developer Studio コンポーネントおよびサポートされる構成

更新 -

注意: オリジナルページ (英語) が更新されている可能性があります。最新の情報については、そちらをご確認ください。

JBoss® Developer Studio のすべてのリリースは、主要なオペレーティングシステム、Java™ 仮想マシン (JVM)、Red Hat JBoss Enterprise Application Platform サーバーおよびテクノロジのさまざまな組み合わせについてテストされ、サポートされています。 JBoss Developer Studio 各リリースのサポートに関する詳細については、以下を参照してください。

JBoss Developer Studio コンポーネント

JBoss Developer Studio リリースは、以下に示す Eclipse および JBoss ツールのコンポーネントバージョンによって構成されます。

JBoss Developer Studio Eclipse バージョン JBoss ツールのバージョン
7 Kepler (4.3) 4.1.x
6 Juno (4.2) 4.0.x
5 Indigo (3.7) 3.3.x
4.1 Helios (3.6) 3.2.x

サポートされる構成

プラットフォームおよびランタイムサーバー

JBoss Developer Studio の各リリースでサポートされている Red Hat JBoss Enterprise Application Platform のバージョンと、JBoss Developer Studio と JBoss EAP との統合インストーラー (カスタマーポータルからダウンロード可能) に含まれる JBoss EAP のバージョンを、以下に示します。

JBoss Developer Studio サポートされる JBoss EAP* 統合されたインストーラーの JBoss EAP
7.1 4.3
5.0、5.1、5.2
6.0、6.1、6.2
6.2.0
7.0 4.3
5.0、5.1、5.2
6.0、6.1
6.1.0
6.0 4.3
5.0、5.1
6.0
6.0.1
5.0 4.3
5.0、5.1
6.0
6.0.0
4.1 4.3
5.0、5.1
5.1.x

* JBoss EAP のこれらのバージョンに基づいた製品 (Red Hat JBoss Fuse Service Works および Red Hat JBoss Portal。以前の名前は JBoss Enterprise SOA Platform および JBoss Enterprise Portal Platform) がサポートされます。

フレームワーク

JBoss Developer Studio の各リリースでサポートするフレームワークを、以下に示します。

JBoss Developer Studio Java EE* Hibernate Seam Richfaces Apache Cordova jQuery Mobile
7.1 5
6
3.5
3.6
4.0
1.1
1.2
2.0
2.1
2.2
3.3.x
4.0.x
3.1 3.1.1
7.0 5
6
3.5
3.6
4.0
1.1
1.2
2.0
3.3.x
4.0.x
6.0 5
6
3.5
3.6
4.0
1.1
1.2
2.0
3.3.x
4.0.x
5.0 5
6
3.5
3.6
4.0
1.1
1.2
2.0
3.3.x
4.0.x
4.1 5 3.5 1.1
1.2
2.0
3.3.x

* Java EE のサポート対象となる製品は、CDI、JavaServer Faces (JSF)、JAX-RS、および JAX-WS となります。

オペレーティングシステムおよび Java Developer Kit

JBoss Developer Studio 各リリースでサポートするオペレーティングシステム、チップアーキテクチャー、Java Developer Kit を以下に示します。

JBoss Developer Studio のすべてのリリースに関する注意

  • JBoss Developer Studio は Eclipse をベースにしているため、Eclipse のシステム要件は JBoss Developer Studio にも適用されます。 たとえば、Linux ディストリビューションのウィンドウシステムには GTK が必要であり、Microsoft Windows オペレーティングシステムには Win32、OS X オペレーティングシステムには Cocoa が必要です。 Eclipse Kepler のシステム要件に関する詳細については、Eclipse に関する以下の Web サイトをご覧ください。
  • Visual Page Editor のビジュアルコンポーネントは XULRunner に依存しているため、OS X および Microsoft Windows オペレーティングシステムにインストールされた 64 ビットバージョンの JBoss Developer Studio では動作しません。 このような制限に対処するには、64 ビットの OS X および Microsoft Windows オペレーティングシステムに 32 ビットバージョンの JBoss Developer Studio (32 ビット Java Developer Kit を含む) をインストールする必要があります。 これにより、JBoss Developer Studio は 32 ビットの JVM で実行されますが、 サーバーおよびその他のアプリケーションは JBoss Developer Studio 内から 64 ビットの JVM で起動できます。
  • Oracle JDK および OpenJDK 1.7 update 40 では、一時ファイルを作成する際に問題が発生することが報告されています (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8025128 および https://bugs.openjdk.java.net/browse/JDK-8025128 を参照)。 JBoss Developer Studio 7.0.1 以降には、この問題に対処するための JBoss Central への修正が含まれますが、別の IDE ツールを使用している場合は問題が発生する場合があります。 この問題が発生した場合は、Java developer kit 1.7 の update 40 以外のバージョンを使用してください。

JBoss Developer Studio 7.0 および 7.1

オペレーティングシステム チップアーキテクチャー Java Developer Kit
Red Hat Enterprise Linux 6 x86、x86_64 OpenJDK 1.6、OpenJDK 1.7、Oracle JDK 1.6、Oracle JDK 1.7
Microsoft Windows XP x86、x86_64 Oracle JDK 1.6
Microsoft Windows 7 および Windows 8 x86、x86_64 Oracle JDK 1.6 および Oracle JDK 1.7
OS X Lion (10.7)*、OS X Mountain Lion (10.8)、OS X Mavericks (10.9)** x86_64 Apple JDK 1.6 および Oracle JDK 1.7 (64 ビットのみ)
Fedora 18 および Fedora 19 x86、x86_64 OpenJDK 1.6 および OpenJDK 1.7
Ubuntu 12.04.2 LTS および Ubuntu 13.04 x86、x86_64 OpenJDK 1.6 および OpenJDK 1.7

* OS X Lion (10.7) は、JBoss Developer Studio 7.0.x および 7.1.0 でのみサポートされます。
** OS X Mavericks (10.9) は、JBoss Developer Studio 7.1.1 でのみサポートされます。

JBoss Developer Studio 6.0

オペレーティングシステム チップアーキテクチャー Java Developer Kit
Red Hat Enterprise Linux 6 x86、x86_64 OpenJDK 1.6、OpenJDK 1.7、Oracle JDK 1.7 (32 ビットのみ)
Microsoft Windows XP x86、x86_64 Oracle JDK 1.6
Microsoft Windows 7 および Windows 8 x86、x86_64 Oracle JDK 1.6 および Oracle JDK 1.7
OS X Lion (10.7) および OS X Mountain Lion (10.8) x86_64 Apple JDK 1.6 および Oracle JDK 1.7 (64 ビットのみ)
Fedora 16 x86、x86_64 OpenJDK 1.7
Fedora 17 x86、x86_64 OpenJDK 1.6 および OpenJDK 1.7
Ubuntu 11.10 x86_64 OpenJDK 1.7 (32 ビットのみ)
Ubuntu 12.10 x86_64 OpenJDK 1.7 (64 ビットのみ)

JBoss Developer Studio 5.0

オペレーティングシステム チップアーキテクチャー Java Developer Kit
Red Hat Enterprise Linux 6 x86、x86_64 OpenJDK 1.6 および Sun JDK 1.6
Microsoft Windows XP、Windows 7、Windows 8 x86、x86_64 Sun JDK 1.6
OS X Lion (10.7) および OS X Mountain Lion (10.8) x86_64 Apple JDK 1.6
Fedora 16 および Fedora 17 x86、x86_64 OpenJDK 1.6
Ubuntu 11.10、Ubuntu 12.04 LTS、Ubuntu 12.10 x86、x86_64 OpenJDK 1.6

JBoss Developer Studio 4.1

オペレーティングシステム チップアーキテクチャー Java Developer Kit
Red Hat Enterprise Linux 5 および Red Hat Enterprise Linux 6 x86、x86_64 OpenJDK 1.6 および Sun JDK 1.6
Microsoft Windows XP および Windows 7 x86、x86_64 Sun JDK 1.6
OS X Leopard (10.5) x86_64 Apple JDK 1.6
OS X Snow Leopard (10.6) x86 Apple JDK 1.6