JBoss Data Grid 7 でサポートされる構成

更新 -

Red Hat JBoss® Data Grid (JDG) のすべてのリリースは、主要なオペレーティングシステム、Java™ 仮想マシン (JVM)、データベースのさまざまな組み合わせについてテストされ、サポートされています。

サポートされる構成

Red Hat は、お客様のサブスクリプション契約に従って、サポートされる構成について、物理環境と仮想環境での実稼働サポートおよび開発サポートを提供します。サポートされる構成で実行するには、以下のいずれかの JVM のバージョンとその JVM のサポート対象となっているいずれかのオペレーティングシステムで JDG を実行する必要があります。Red Hat は基盤となる JVM のテストと認定プロセスに依存してプラットフォームの互換性を検証しています。1 Red Hat による OpenJDK のサポートは、Red Hat Enterprise Linux に限定されます。

テスト済みの構成

テスト済みの構成とは、検証が行われ、推奨されているオペレーティングシステム、チップアーキテクチャー、JVM、データベースの組み合わせの定義済みセットのことです。これらは、JBoss Enterprise Middleware を使用しているお客様が選択される最も一般的な組み合わせです。

以下のテスト済みの構成に対して、Red Hat は幅広いプラットフォームテストを実施しています。

サポートされる構成: JBoss Data Grid 7.1

Java 仮想マシン バージョン
OpenJDK 1.8
Oracle JDK 1.8
IBM JDK 1.8
Azul Zing 1.8

テスト済みの構成: JBoss Data Grid 7.1

オペレーティングシステム チップセットアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 7 (最新のアップデート) x86_64 Oracle JDK 1.8
IBM JDK 1.8
OpenJDK 1.8
Azul Zing 1.8 (Build 16.12.0.0-12)
Red Hat Enterprise Linux 6 (最新アップデート) x86_64 Oracle JDK 1.8
IBM JDK 1.8
OpenJDK 1.8
Windows Server 2012 x86_64 Oracle JDK 1.8
Windows Server 2008 x86_64 Oracle JDK 1.8
Oracle Solaris 10 x86_64
SPARC64
Oracle JDK 1.8
Oracle Solaris 11 x86_64
SPARC64
Oracle JDK 1.8

JBoss Data Grid 7.1 リリースの一部として、以下のデータベースおよびデータベースドライバーがテストされました。

データベース バージョン (JDBC Driver のバージョン)
MySQL 5.5 MySQL Connector/J 5.1.38
MySQL 5.7 MySQL Connector/J 5.1.38
Oracle 11g R2 Oracle JDBC Driver v12.1.0.2.0
Oracle 11g R2 RAC Oracle JDBC Driver v12.1.0.2.0
Oracle 12c Oracle JDBC Driver v12.1.0.2.0
Oracle 12c RAC Oracle JDBC Driver v12.1.0.2.0
PostgreSQL 9.3 JDBC4 Postgresql Driver バージョン 9.4-1207
PostgreSQL 9.4 JDBC4 Postgresql Driver バージョン 9.4-1207
Microsoft SQL Server 2012 SP3 Microsoft SQL Server JDBC Driver 4.2.6420.100
Microsoft SQL Server 2014 SP1 Microsoft SQL Server JDBC Driver 4.2.6420.100
Sybase 15.7 JDBC(TM)/7.07 ESD #5 (Build 26792)/P/EBF20686
IBM DB2 9.7 IBM DB2 JDBC Universal Driver Architecture 4.14.146
IBM DB2 10.5 IBM DB2 JDBC Universal Driver Architecture 4.19.26
Enterprise DB Postgres Plus Advanced Server 9.3 Postgres Plus Advanced Server Driver 9.3 (9.3.1.3)
Enterprise DB Postgres Plus Advanced Server 9.4 Postgres Plus Advanced Server Driver 9.4 (9.4.1.3)
MariaDB 10.1.10 MariaDB Connector/J 1.3.4

JDG はランタイム用のアプリケーションサーバーは必要としません。また JDG は サポート対象の JVM でコンテナーを使用せずにアプリケーションと共にデプロイされた場合にサポートされます。JDG 7.1 のライブラリーモードは、以下のコンテナーでテストされました。

アプリケーションコンテナー バージョン
JBoss Enterprise Application Platform 7 7.0.5
JBoss Enterprise Application Platform 6 6.4.13
JBoss Web Server (Tomcat 7) 3.0.3
JBoss Web Server (Tomcat 8) 3.0.3
Apache Karaf 2.4.0, 3.0.3
Oracle WebLogic Server 12c 12.1.3.0

JDG 7.1 の Hot Rod Java クライアントは以下のコンテナーでテストされました。

アプリケーションコンテナー バージョン
JBoss Enterprise Application Platform 7 7.0.5
JBoss Enterprise Application Platform 6 6.4.13
JBoss Enterprise Application Platform 5 5.2
JBoss Web Server (Tomcat 7) 3.0.3
JBoss Web Server (Tomcat 8) 3.0.3
Apache Karaf 2.4.0、3.0.4

JDG 7.1 の camel-jbossdatagrid コンポーネントは、以下の Red Hat JBoss 統合製品でテストされました。

製品 バージョン
JBoss Fuse 6.3.0
JBoss EAP 7.0.5 (Apache Camel 2.17.0)

以下の製品は JDG 7.1 との統合についてもテストされました。

製品 バージョン
Apache Spark 1.6.0 および 2.0.0
Hadoop 2.7.1
Spring 4.1.0

サポートされる構成: JBoss Data Grid 7.0

Java 仮想マシン バージョン
OpenJDK 1.8
Oracle JDK 1.8
IBM JDK 1.8
Azul Zing 1.8

テスト済みの構成: JBoss Data Grid 7.0

オペレーティングシステム チップセットアーキテクチャー Java 仮想マシン
Red Hat Enterprise Linux 7 (最新のアップデート) x86_64 Oracle JDK 1.8
IBM JDK 1.8
OpenJDK 1.8
Azul Zing 1.8 (Build 16.01.1.0-b2)
Red Hat Enterprise Linux 6 (最新アップデート) x86_64 Oracle JDK 1.8
IBM JDK 1.8
OpenJDK 1.8
Windows Server 2012 x86_64 Oracle JDK 1.8
Windows Server 2008 x86_64 Oracle JDK 1.8
Oracle Solaris 10 x86_64
SPARC64
Oracle JDK 1.8
Oracle Solaris 11 x86_64
SPARC64
Oracle JDK 1.8

JBoss Data Grid 7.0 リリースの一部として、以下のデータベースおよびデータベースドライバーがテストされました。

データベース バージョン (JDBC Driver のバージョン)
MySQL 5.5 MySQL Connector/J 5.1.38
MySQL 5.7 MySQL Connector/J 5.1.38
Oracle 11g R2 Oracle JDBC Driver v12.1.0.2.0
Oracle 11g R2 RAC Oracle JDBC Driver v12.1.0.2.0
Oracle 12c Oracle JDBC Driver v12.1.0.2.0
Oracle 12c RAC Oracle JDBC Driver v12.1.0.2.0
PostgreSQL 9.3 JDBC4 Postgresql Driver バージョン 9.4-1207
PostgreSQL 9.4 JDBC4 Postgresql Driver バージョン 9.4-1207
Microsoft SQL Server 2012 SP2 Microsoft SQL Server JDBC Driver 4.2.6420.100
Microsoft SQL Server 2014 Microsoft SQL Server JDBC Driver 4.2.6420.100
Sybase 15.7 JDBC(TM)/7.07 ESD #5 (Build 26792)/P/EBF20686
IBM DB2 9.7 IBM DB2 JDBC Universal Driver Architecture 4.14.146
IBM DB2 10.5 IBM DB2 JDBC Universal Driver Architecture 4.19.26
Enterprise DB Postgres Plus Advanced Server 9.3 Postgres Plus Advanced Server Driver 9.3 (9.2.1.3)
Enterprise DB Postgres Plus Advanced Server 9.4 Postgres Plus Advanced Server Driver 9.4 (9.3.1.3)
MariaDB 10.1.10 MariaDB Connector/J 1.3.4

JDG はランタイム用のアプリケーションサーバーは必要としません。また JDG は サポート対象の JVM でコンテナーを使用せずにアプリケーションと共にデプロイされた場合にサポートされます。JDG 7.0 のライブラリーモードは、以下のコンテナーでテストされました。

アプリケーションコンテナー バージョン
JBoss Enterprise Application Platform 7 7.0.0
JBoss Enterprise Application Platform 6 6.4.7
JBoss Web Server (Tomcat 7) 3.0.2
JBoss Web Server (Tomcat 8) 3.0.2
Apache Karaf 2.4.0、3.0.0
Oracle WebLogic Server 12c 12.1.3.0

JDG 7.0 の Hot Rod Java クライアントは以下のコンテナーでテストされました。

アプリケーションコンテナー バージョン
JBoss Enterprise Application Platform 7 7.0.0
JBoss Enterprise Application Platform 6 6.4.7
JBoss Enterprise Application Platform 5 5.2
JBoss Web Server (Tomcat 7) 3.0.2
JBoss Web Server (Tomcat 8) 3.0.2
Apache Karaf 2.4.0、3.0.0

JDG 7.0 の camel-jbossdatagrid コンポーネントは以下の Red Hat JBoss 統合製品でテストされました。

製品 バージョン
JBoss Fuse 6.2.1
JBoss EAP 7.0.0 (Apache Camel 2.15.1)

以下の製品は、JDG 7.0 との統合についてもテストされました。

製品 バージョン
Spring 4.1.0
Apache Spark 1.6.0
Hadoop 2.7.1

  1. Red Hat では、サポートされる環境をお客様が引き続き利用されることを前提としています。ベンダーが JVM、オペレーティングシステム、データベースなどのサポートを終了した場合 (特定のバージョンのサポートを含む) は、Red Hat が提供するサポートが限定される可能性があります。サポートを継続するには、サポートされる環境における問題再現をお客様にお願いする場合があります。