In RHEL7 how do I enable XDMCP?

Latest response

Tried the following steps:

  • Installed GDM packages using command line:
    yum install gdm -y

Edited /etc/gdm/custom.conf file and added the foolowing entries:
[xdmcp]
Enable=true

[security]
DisallowTCP=false
AllowRemoteRoot=true

  • Rebooted RHEL7.

On the X server, tried XDMCP connection to RHEL7 host, got back message: "Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again."

Thank you for your attention.

Responses

Hi Gus,

I do not know if this post will help, I hope some of this below helps...
- Are you dealing with an IBM system?
- This documentation at Red Hat speaks a bit on XDMPC, HOWEVER, the title at that link says it is for 'Enabling XDMCP on IBM System z'
- At that location, it says "for more information, see http://www.x.org/releases/X11R7.6/doc/libXdmcp/xdmcp.html

Let us know how this goes, and if any of the above applies for you...
Kind Regards,

Same problem here. I want to use Exceed 14.0.11.693 on Win8.1 to connect to RHEL7 Server GUI. It works fine with RHEL4, RHEL5 and RHEL6. Server and Client are registered in DNS, selinux and firewall are already disabled, Exceed is configured to allow connections from all hosts. The RHEL7 Server shows up in Exceeds XDMCP hostchooser, but connecting to it fails with "Oh no! Something has gone wrong ..."

The Exceed logfile says:
"Client is not authorized to connect to Server during XDMCP negotiation process."

The RHEL7 log says:
Aug 13 12:48:02 hostname dbus-daemon: dbus[1336]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.74" (uid=0 pid=4127 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.381" (uid=0 pid=19705 comm="/usr/libexec/gdm-simple-slave --display-id /org/gn")

Regards,

Has anyone been able to get this to work to an IBM powerlinux LPAR? I've tried using xdmcp via mobaxterm and can not get a desktop.

I can use mobaxterm to get to my AIX lpar and start a CDE no problem.

I can use VNX to get to my powerlinux LPAR no problem and start gnome.

But if I use xdmcp i only get a blank screen.

Thanks,

Arthur

Might it be a permissions issue? https://help.gnome.org/admin/gdm/stable/troubleshooting.html.en_GB

I'd suggest enabling debug info, too — in /etc/gdm/custom.config file, under [debug] add 'Enabled=true'. Then restart the service:
systemctl restart gdm.service

Leo, you may also want to try reloading dbus.

Hi Laura,

Thanks for that. I double checked the permissions and there was no issue there.
I turned on debugging and restarted the service but I'm not seeing any new debug logs in /var/log/gdm.

I think that there is a fundamental problem in the desktop design with regards to usability and maintainability. There is no automatic fallback to a minimal "safe-mode" desktop when the "Something went wrong" message appears. I have seen this happen when Gnome GDM failed to start because of the fingerprint scanner module and/or the smartcard module for PAM failed. In each case I had a machine with neither smartcard or fingerprint ability. There was no way to trouble-shoot this without flipping over to a terminal and trouble-shooting from the command-line. This was less that optimal because the terminal width is fixed and too limited in width to use the log conveniently.

I have seen other things that are not essential prevent the desktop from starting including bad sound drivers. It should be a fundamental requirement of all desktop designs to have a fallback mode with the absolute minimum of requrements. That means no services running, vesa graphics, and no sound. The network should only be started manually.

I have just been trouble-shooting a gnome respawning too fast problem in a KVM virtual machine. gnome provided no practical assistance to fix this. I only got the VM up by replacing gnome.

Has anybody gotten this to work? I don't even get the "Oops" page -- mine is nothing but black, no matter what OS/application I try to connect from.

The only GNOME3 crashes on EL7 I have had were all SELinux related and pertaining specifically to the NVIDIA kmod after an update of the kernel or kmod. Fixing the AVC made the crash disappear, or disabling SELinux.

As for your config, I cant see anything wrong there. Its been a long time since I had setup XDMCP anywhere in production, and for sh!ts and giggles I did it on RHEL 7.0 on my home servers just to see what was faster (ended up using X2Go). I do recall having various things over my time administering and using EL7 that did need fiddling with SELinux. Unusure if that would be the case here. Note, I keep SELinux enabled on ALL systems as it never really can hurt to have it on, rather only when not present.

getting the below error while connecting to graphics terminal using xmanager

Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again."

Something appears to be broken in RHEL7.x I'm no longer able to connect via xdm to a remote RHEL6 from a RHEL7 console terminal using the command:

"X :0 -query rhel6_server_ip

Solved by copying the "org.freedesktop.color-manager.create-device" policy from my RHEL7.2 box. It was missing on my RHEL7.3, I would post it but I'm having formatting issues posting an xml file.

I found this while dealing with an Exceed On Demand + RHEL7 issue and just wanted to share/add this, from their site about 3D Desktop Support: "...The reason that GNOME 3.8+ does not work with OpenText Exceed onDemand (EoD) is unrelated to performance. This issue is caused by GNOME's use of unsupported X protocol extensions (XFIXES 5.0 and XInputExtension 2.2) which are not available in EoD's older X.Org server codebase. To connect to GNOME 3 desktops, EoD customers should upgrade to ETX, which uses the latest X.Org codebase..." See: https://www.opentext.com/support/connectivity-support-statements/3d-desktop

still i face the same problem . i am trying to connect from a windows machine with xmanager installed. when i open the xmanager broadcast i see the hostname of the RHEL 7.3 in the list. but when clicked i get a blank screen and a message is seen "Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again."

let me know how to resolve this XDMCP issue in RHEL 7.3