Insufficient Software Channel Entitlements

Latest response

Recently I've upgraded our Server from RHEL 5 to 6.5.
So after I finished the installation I tried to register this system into my account so I'm able to receive updates from YUM.
But when I try to register this server I receive the following message:

===========================================================================================
Error communicating with server. The message was:

Error Message:
Insufficient Software Channel Entitlements:

cfid8960  Red Hat Enterprise Linux Server (v. 6)

note: One of the above Software Channel Entitlement(s) are required
to provides access to: cid10486 Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)
Error Class Code: 70
Error Class Info:
All available subscriptions for the requested channel have been exhausted.
Please contact a Red Hat Network Sales associate.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

===========================================================================================

It doesn't matter if I try it with:
- rhn_register
- subscription_manager register
- rhnreg_ks

And even the --force option doesn't work.
I've logged in as well, but I cant find the 'old' installation of this server on my account.
What do I need to do to re-register and get my updates :-).

Thanks in advance.

Responses

Have you looked at the RHN customer portal to see if the machine is already registered there.

Chances are your machine with the old OS is still taking up your license.

Suggest you go there delete the machine and try registering it again.

I've searched everywhere, but I'm not able to find anything...
That is the strange part.

there are 2 places where it could be.

on the customer portal (access.redhat.com)

1: under subscriptions -> subscription management -> units

or

2: under subscriptions -> RHN Classic -> Registered Systems

hope this helps

Well I've found this system with Option 1.
I've deleted it, but it did not help.
Still the same message. (Reboot of server did not help as well)

ok so you now have nothing under option 1 or 2, right?

then try
# subscription-manager unregister
# subscription-manager clean

Also ensure that your subscription is still active you should be able to see it in:
under subscriptions -> Your Subscriptions -> Overview

you should see something under active subscriptions

No I didn't and tried your option.
But this didn't work as well.

Thanks!

If I am understanding this correctly - I believe you need to contact Red Hat to change your entitlement from Red Hat Enterprise 5 to 6.

I apologize if I did not understand the situation correctly.

I will contact the Helpdesk and ask for their help!
Thanks!

Cool - once you have an resolution, please update this thread (in case someone else runs in to this same issue). I am not positive you need an RHEL 6 entitlement (to replace your RHEL 5) - but it seems like you would.

I've just send an E-Mail with my question.
I'll let you know when I know more and if it was the solution yes or no.

I've got the same problem.
Is there any solution for this problem.
Please let me know~!!

This blog has fixed my issue. I had problems due to too many systems entitled in RHN. After removing systems with obsolete OS versions I too had issues contacting xmlrpc.rhn.redhat.com but was fixed after giving close attention to /etc/sysconfig/rhn/up2date file. Account used to go via proxy was locked out and unlocking the account fixed it for me. Good post guys keep it up. Thanks

You are trying to register your system with RHN but please be informed RHN is deprecated now. Try :

subscription-manager register

///////

subscription-manager attach --auto