Force removing a host from within the RHEV GUI

Latest response

Fellow RHEV enthusiasts,

I have come across a frustrating quirk in the RHEV interface that I am hoping someone will have a fix for.

Essentially I have a host listed in the RHEV console which no longer exists (unplugged) but there doesn't appear to be a way to forcefully remove the host from the cluster.

I can plug the host back in again, and re-establish communication with it to remove it, but this seems a little absurd.

The right click context menu has 'Remove' greyed out.. likely because the host is currently 'unresponsive' and as a result can't be put into maintenance mode.

The issue was also raised here for an older version:
https://access.redhat.com/site/solutions/37114

In summary, I understand there is likely a 'clean' procedure to remove a host from the cluster, but surely I shouldn't need the host up and responsive to force remove it from the cluster?

Responses

Hello, thanks for the discussion on this. It's tough to answer without looking at the exact state of the environment. An unresponsive host should still be able to enter Maintenance mode so there may be something else going on that is currently unseen. However, there are typically 2 reasons that you would be unable to remove a host:

  1. If the host is currently the SPM (Storage Pool Manager).
  2. If the host is the only host in the cluster.

Offhand, there are 3 possible solutions to the issue:

  1. Temporarily add this system back in, put it into Maintenance mode, then Remove it.
  2. Add another host to the cluster
  3. Hack the RHEV database with a SQL command provided by Red Hat Support

If you need additional assistance resolving this issue, please open a case with Red Hat Support or refer to the following article:

How do I remove a Non Responsive RHEV Hypervisor if it is currently the Storage Pool Manager?

Hi Bryan, thanks for the response. I ended up reluctantly solving the issue with option 1 (connecting it back to the cluster then removing it).

I explicitly wanted it to do it through the GUI as it seems like a failing in design that one can't forcefully remove a reference to a host from within the GUI.

I had read the support guideline on removing the host by directly modifying the database but the issue is more theoretical than technical.. yes one can forcefully remove it from the database.. but should a user expect that level of interaction is required for what seems like such a trivial task?

In saying all that, I am not sure it is worthy of a bug ticket..

Thanks again.

In daily operation, the user should not ever have to edit the database directly. That is why most of our knowledge solutions that involve direct database edits instruct the customer to open a support case first.

That being said, I would disagree that it's not worthy of a bug ticket. In my opinion, anything that detracts from the user experience is worth of a bug ticket. If you end up filing one, please direct your support engineer to this discussion and have them reach out to me.

I think you could have resolved this by following below steps.

1 - Right click on the host and click "Confirm Host has been rebooted".
2 - Move to maintenance. This will hopefully succeed as #1 is likely to remove the blocking factor that you encountered earlier.
3 - Right click and Remove.

Sorry I couldn't jump earlier.

I'm currently running into this problem. I have a host in maint mode that I cannot remove. I have tried what Sadique suggested but I still get the error "Failed to remove Host".

I was in the same situation. Renaming the host allowed e to remove it ... I will post when I try to add a host with the same name .

The proper way to do that is to just Destroy Local Storage (before a hypervisor should be put into the Maintenance mode, if it is broken first right click and mark 'host has been rebooted') Normally you can't just remove hypervisor if there are VMs deployed and there is a Storage Domain. To remove SD, there is needed the Storage Pool Manager (SPM), in a case, you have broken hypervisor and Local Storage Domain, of course, it is not possible to bring SPM up. "Destroy" removes VMs and clears DB's records related to the local SD.