RH certified collection 'microsoft.ad' missing modules when used with execution environment

Latest response

I'm having very limited success with building custom execution environments that have the collections I need. In this case, the collection I need is the 'microsoft.ad' collection (available on either RH Automation Hub or galaxy.ansible.com).

I have the collection and it's dependencies listed in requirements.yml/txt (I've also added these within the execution-environment.yml for v3). The execution environment appears to build as expected, and when I run 'ansible-navigator collections' the collection appears to be installed. However, further inspection of the collection reveals that it's missing some of the modules/plugins. Depending on which version of the collection I install, different modules are missing. If I install the collection externally from the environment in a subdirectory of my working directory (./collections), the same thing happens; ansible-navigator sees the collection as installed but a bunch of things are missing. If I install the collection externally in (~/.ansible) it gets installed and can be used as expected by ansible, ansible-playbook and other 'non-ee' versions of the software.

I've had a support case open with RH for nearly a month. This is preventing us from moving off of Tower.



Been where you're at really recently, and found a hidden gem made by a Red Hat employee here. This solved my issues goes into great detail. https://autodotes.com/posts/xnl1o59Sdls9p7vZleBf

I did run into a weird bug in my test environment, but ultimately, I rebuilt, and this worked just fine. I hope you find this awesome resource as valuable as I have. I really wish Red Hat would duplicate the content and create a similar community repository for everyone to share similar goodies!