Disable CPU Accounting on RHEL 8?

Latest response

I have a new RHEL 8.6 server where I have installed software from Oracle. I am getting software errors that are linked to the cpu.rt_runtime_us for user.slice being set to 0. If I use a workaround and change the value of cpu.rt_runtime_us to a non-zero value like 950000, then my software errors go away. The problem is that the update to cpu.rt_runtime_us does not persist through a server restart.

I have not tried to explicitly enable CPU Accounting. I'm not sure why it seems to be enabled. I am looking for advice on whether to disable it and if so, how to disable it.

I have reviewed Red Hat documents "How to configure a RHEL 7 or RHEL 8 system to be able to run programs requiring Real-Time Scheduling" and "Processes requiring Real-Time Scheduling fail with "sched_setscheduler: Operation not permitted"

I have verified that systemd makes use of the cpu and cpuacct cgroup controllers by using the command:
ls -d /sys/fs/cgroup/{cpu,cpuacct}/.slice
This returns directories for system.slice and user.slice.
I have verified that systemd is not configured to enable CPU Accounting at boot by using this command:
grep ^DefaultCPUAccounting= /etc/systemd/system.conf
I have verified that initramfs is not configuring CPU Accounting at boot using this command:
lsinitrd /boot/initramfs-$(uname -r).img /etc/systemd/system.conf | grep ^DefaultCPUAccounting=
So CPU Accounting is not enabled at boot but it is being enabled somehow? I used this command:
egrep -ri "^(Startup)?CPU.
=(.*%|1|yes|true|on)" /usr/lib/systemd/system
And it returns these lines:
/usr/lib/systemd/system/insights-client-boot.service:CPUQuota=30%
/usr/lib/systemd/system/insights-client.service:CPUQuota=30%

I would be grateful for any recommendations about how/whether to disable CPU Accounting to prevent runtime errors on user processes.

Responses

We have the same issue. Can anybody please help on this topic?