Unable to start dynflow-sidekiq@orchestrator.service with satellite-maintain service

Latest response

I am running RHEL 7.9, Satellite 6.10

satellite-maintain service status -b:
shows that dynflow-sidekiq@orchestrator.service, foreman, dynflow-sidekiq@worker-1 and dynflow-sidekiq@worker-hosts-queue-1 all do not start.

I tried all the recommended solutions from the KB, none work.

sudo su - postgres -c "psql -d foreman -c 'select label,count(label),state,result from foreman_tasks_tasks where state <> '\''stopped'\'' group by label,state,result ORDER BY label;'"

This does not show a large number of tasks, only about 10.
I did a clean up anyway, also to no avail:

foreman-rake foreman_tasks:cleanup TASK_SEARCH='label ~ *' AFTER='30d' VERBOSE=true NOOP=false

as foreman, I got into psql, it did not help.

foreman=# update settings set value=false where name='fix_db_cache';
UPDATE 1
foreman=# commit;

Trimming the database did not help. Any other ideas?

su - postgres

psql foreman
truncate dynflow_coordinator_records;
exit
exit

satellite-maintain service restart

Responses

Also from /var/log/messages, I see a lot of:

dynflow-sidekiq@orchestrator: could not connect to server: Permission denied

Same thing for worker-hosts-queue-1

The mystery has been solved. SELinux has been blocking this, when I did setenforce 0 it became permissive and now everything starts.

However, I still cannot get to the web gui of the satellite. It times out.

Hello, indeed, if also foreman service was failing, then just manipulating with dynflow / tasking system will probalby not help.

For the SELinux in permissive mode: in case you prefer having it in Enforcing mode, let review /var/log/audit/audit.log file - even with permissive mode, the log wile will contain some AVCs that block startup in Enforcing mode.

If WebUI times out, I would check /var/log/httpd/*log files or /var/log/foreman/production.log for more - or open a support case to us / Red Hat for better support.