Virtualization option is not showing up in the workload

Latest response

Hi team,

We installed OpenShift on our VMware using IPI.

But, virtualization was not enable. We stopped the server, and enable virtualization after 24 hours, as we read it some blog post that we should wait minimum 24 hours for certificate to rotate else cluster may go into inconsistent state.

We restarted but virtualization option is no longer showing up in workload. Deleted/uninstall the Virtualization operator, deleted all the kubevirt related CRD, and installed it again. Also, created new instance of hyper converged.

All pods are running, but virtualization option is not showing up in the workload section.

If I go to home, it shows kubevirt plugin is degraded. I checked online forums to get some help in troubleshoot this, but no success.

I deleted the console plugin, and re-created too, in case if it changes anything, but it didn't help.

OCP version: 4.11.1

Responses

Image snippet for reference

https://res.cloudinary.com/dg5js0swr/image/upload/v1663307421/ocp_xkaw79.png

i created a VM by going to Administrator > CRD > added VM YAML file I started the machine too, and it is working as expected.

So, that means installation is successful and components are working as expected. Issue seems to be on Openshift unable to show workload section