Xorg -configure exec failed on rhel9

Latest response

I tried to use the command "Xorg -configure :1 " to create the file xorg.conf.new, but it is failed and reported an error like "No devices to configure. Configuration failed.".

Could somebody have a look at this?

Responses

If your kernel parameters contain 'nomodeset' or 'nofb', it may be worth a try to remove those with grubby, for example:

grubby --update-kernel=/boot/vmlinuz-$(uname -r) --remove-args="nomodeset nofb"

... and reboot. In my case, all connected displays can be used now with their native panel resolutions where the was just one (low-rez, wrong aspect ratio) before.

Hope it helps, cheers!

I tried to run above grubby command and reboot the system, seems that it still report the error like "No devices to configure. Configuration failed." when run Xorg -configure command.

From the /var/log/Xorg.1.log, There is an error "/dev/dri/card0: failed to set DRM interface version 1.4: Permission denied", not sure this error will lead the failure of running the command Xorg -configure.

Seems that the command Xorg -configure runs well on rhel7 and rhel8 , but failed on rhel9, is it a system issue of rhel9?